Build Error - Windows Embedded C7 on i.MX53 SMD

cancel
Showing results for 
Search instead for 
Did you mean: 

Build Error - Windows Embedded C7 on i.MX53 SMD

808 Views
Contributor I


I am trying to do an initial build of the Windows Embedded 7 Compact BSP for the i.MX53 SMD board.

I am doing a SYSGEN, and it gets quite a way into the build and then gets the following error(s):

 

BUILD: [01:0000011253:ERRORE] Error(s) in directory "C:\WINCE700\platform\common\src\soc\MX53_FSL_V3\ACCELEROMETER\MDD\". {log="C:\WINCE700\build.log(41942)"}

BUILD: [01:0000011254:ERRORE] c:\wince700\platform\common\src\soc\mx53_fsl_v3\accelerometer\mdd\accdevice.cpp(122) : error C2440: '=' : cannot convert from 'void (__cdecl *)(DWORD,ACC_DATA *)' to 'PFN_ACC_MDD_PROCESSSAMPLE' {log="C:\WINCE700\build.log(41943)"}

BUILD: [01:0000011260:ERRORE] NMAKE : fatal error U1077: 'C:\WINCE700\sdk\bin\i386\ARM\cl.EXE' : return code '0x2' {log="C:\WINCE700\build.log(41949)"}

BUILD: [01:0000011262:ERRORE] clean TargetCompilePass -nologo BUILDMSG=Stop. BUILDROOT=C:\WINCE700\platform\common CLEANBUILD=1 NOLINK=1 NOPASS0=1 failed - rc = 2. {log="C:\WINCE700\build.log(41951)"}

BLDDEMO: ERROR: There were errors building CEBASE. {log="C:\WINCE700\build.log(41983)"

It seems like there is a code issue in the Accelerometer code.

Any help on this would be appreciated.

Thanks,

Mike

Labels (2)
0 Kudos
3 Replies

7 Views
Senior Contributor IV

Mike

This discussion is closed since no activity. If you still need help, please feel free to reply with an update to this discussion or create another discussion.

Thanks,

Yixing

0 Kudos

7 Views
Senior Contributor IV

Mike

Has your issue resolved? If yes, we are going to close the discussion in 3 days. If you still need help please feel free to contact Freescale.

Thanks,
Yixing

0 Kudos

7 Views
Contributor I

I had exactly the same error when building for the iMX51 EVK Mobility.

I found this link in the MSDN very useful: Build fails after installing updates

So although I didn't find out how to disable building the accelerometer driver, the solution is simply putting a typecast in the assignment. Line 122 of the accdevice.cpp must look like this:

callbackInfo.pfnAccMddProcessSample = (PFN_ACC_MDD_PROCESSSAMPLE) AccMddProcessSample;

For me this fixed the problem.

Best regards,

Matthias

0 Kudos