Bluetooth is not working with Imx8 Nano evk Board

cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth is not working with Imx8 Nano evk Board

194 Views
Contributor II

Dear Nxp,

I am using Imx8 nano evk board and the bluetooth module is connected to imx uart1.

now i am following below steps to connect ble module but it is showing timeout, what can we the issue??

root@ccu:~# hciattach ttymxc0 any 115200 noflow                                                                                                                                                

Setting TTY to N_HCI line discipline
Device setup complete
root@ccu:~# [   99.998109] Bluetooth: hci0: command 0x1003 tx timeout
[  100.004573] Bluetooth: hci0: Frame reassembly failed (-84)
[  100.010106] Bluetooth: hci0: Frame reassembly failed (-84)
[  100.015622] Bluetooth: hci0: Frame reassembly failed (-84)
[  102.014104] Bluetooth: hci0: command 0x1001 tx timeout
[  104.030104] Bluetooth: hci0: command 0x1009 tx timeout
root@ccu:~# hciconfig -a
hci0:   Type: Primary  Bus: UART
        BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0
        DOWN
        RX bytes:5120 acl:0 sco:0 events:0 errors:0
        TX bytes:12 acl:0 sco:0 commands:3 errors:0
        Features: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
        Packet type: DM1 DH1 HV1
        Link policy:
        Link mode: SLAVE ACCEPT
root@ccu:~# hciconfig hci0 up
[  132.478107] Bluetooth: hci0: command 0x1003 tx timeout
[  134.494103] Bluetooth: hci0: command 0x1001 tx timeout
[  136.510105] Bluetooth: hci0: command 0x1009 tx timeout
Can't init device hci0: Connection timed out (110)      
root@ccu:~# bluetoothctl
Agent registered
[bluetooth]# scan on
No default controller available
Labels (1)
0 Kudos
1 Reply

141 Views
NXP TechSupport
NXP TechSupport

pls refer to the document as below, how about use "hciattach /dev/ttymxc0 any -s xxxxx"?

"https://community.nxp.com/docs/DOC-345974 "

0 Kudos