BUILD META-TOOLCHAIN-QT5 for iMX8mnevk fail.

cancel
Showing results for 
Search instead for 
Did you mean: 

BUILD META-TOOLCHAIN-QT5 for iMX8mnevk fail.

299 Views
hotanha03021996
Contributor II

when I use yocto to build meta-toolchain-qt5 for iMX8mnevk: $ bitbake meta-toolchain-qt5. I have a problem:

ERROR: nativesdk-qtbase-5.10.1+gitAUTOINC+6c6ace9d23-r0 do_prepare_recipe_sysroot: Error executing a python function in exec_python_func() autogenerated:

The stack trace of python calls that resulted in this exception/failure was:
File: 'exec_python_func() autogenerated', lineno: 2, function: <module>
0001:
*** 0002:extend_recipe_sysroot(d)
0003:
File: '/home/usr/imx-yocto-bsp/sources/poky/meta/classes/staging.bbclass', lineno: 545, function: extend_recipe_sysroot
0541: dest = newmanifest[l]
0542: if l.endswith("/"):
0543: staging_copydir(l, targetdir, dest, seendirs)
0544: continue
*** 0545: staging_copyfile(l, targetdir, dest, postinsts, seendirs)
0546:
0547: bb.note("Installed into sysroot: %s" % str(msg_adding))
0548: bb.note("Skipping as already exists in sysroot: %s" % str(msg_exists))
0549:
File: '/home/usr/imx-yocto-bsp/sources/poky/meta/classes/staging.bbclass', lineno: 151, function: staging_copyfile
0147: os.symlink(linkto, dest)
0148: #bb.warn(c)
0149: else:
0150: try:
*** 0151: os.link(c, dest)
0152: except OSError as err:
0153: if err.errno == errno.EXDEV:
0154: bb.utils.copyfile(c, dest)
0155: else:
Exception: FileExistsError: [Errno 17] File exists: '/home/usr/imx-yocto-bsp/build-xwayland/tmp/sysroots-components/x86_64-nativesdk/nativesdk-glibc/opt/fsl-imx-xwayland/4.14-sumo/sysroots/x86_64-pokysdk-linux/usr/share/x86_64-pokysdk-linux_config_site.d/glibc_config' -> '/home/usr/imx-yocto-bsp/build-xwayland/tmp/work/x86_64-nativesdk-pokysdk-linux/nativesdk-qtbase/5.10.1+gitAUTOINC+6c6ace9d23-r0/nativesdk-recipe-sysroot/opt/fsl-imx-xwayland/4.14-sumo/sysroots/x86_64-pokysdk-linux/usr/share/x86_64-pokysdk-linux_config_site.d/glibc_config'

ERROR: nativesdk-qtbase-5.10.1+gitAUTOINC+6c6ace9d23-r0 do_prepare_recipe_sysroot: Function failed: extend_recipe_sysroot
ERROR: Logfile of failure stored in: /home/usr/imx-yocto-bsp/build-xwayland/tmp/work/x86_64-nativesdk-pokysdk-linux/nativesdk-qtbase/5.10.1+gitAUTOINC+6c6ace9d23-r0/temp/log.do_prepare_recipe_sysroot.29764
ERROR: Task (/home/usr/imx-yocto-bsp/sources/meta-qt5/recipes-qt/qt5/nativesdk-qtbase_git.bb:do_prepare_recipe_sysroot) failed with exit code '1'

What is it? How can I solve it?

I am using Ubuntu 18.04 for host computer.

0 Kudos
2 Replies

162 Views
hotanha03021996
Contributor II

Thanks gusarambula‌.

I use iMX8mnevk with imx-yocto-L4.13.98_2.3.0 guide from i.MX Software and Development Tools | NXP 

When I built image with "bitbake fsl-image-validation-imx" and DISTRO="fsl-imx-xwayland", it had no error. I tried to build image with qt5 "bitbake fsl-image-qt5-validation-imx", it had many errors and I tried to fix them.

I have followed all the step on the i.MX Yocto User’s Guide and tried any time but that error still happened.

I have to download and use Linux image example L4.14.98_2.3.0_images_MX8MNEVK to test some my application.

0 Kudos

162 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Ho Tan Ha,


Which BSP are you using and, have you followed all the steps on the i.MX Yocto User’s Guide which is included with the BSP documentation?


This error may be caused by a missing package on the host configuration. Usually Ubuntu 16.04 is recommended, but you may try Ubuntu 18.04 after installing all the required packages mentioned on the documentation.


Regards

0 Kudos