Audio testing fails with tinyplay command on i.MX8M EVK

cancel
Showing results for 
Search instead for 
Did you mean: 

Audio testing fails with tinyplay command on i.MX8M EVK

2,610 Views
deexithamba
Contributor III

Hello,

Tinyplay utility fails to play a sample audio wav file when followed with the below steps on Android platform,

evk_8mq:/storage/emulated/0 # tinyplay testw2.wav

Unable to open PCM device 0 (cannot set hw params: Invalid argument)

No parameters are observed under ctl,type,num,name and value fileds.Tinymix displays the following content 

evk_8mq:/storage/emulated/0 # tinymix
Mixer name: 'wm8524-audio'
Number of controls: 0
ctl       type      num       name       value

Can you please provide me some inputs on this?

Regards,

Deexith    

0 Kudos
4 Replies

905 Views
amber_yeh
Contributor I

Hello,

The wm8524-codec supports 32000hz, 48000hz, 96000hz and 192000hz.

Some wav files are 44100hz sample rate so you can covert wav files of some frequency to 48000 hz.

Regards,

Yilin

0 Kudos

905 Views
xiaocong_fu
NXP Employee
NXP Employee

Hi Deexith,

 

Check the sound card using cat /proc/asound/card0/id

if the id is wm8524audio, and you see pcm0p in card0, try to specify device and card using:

tinyplay test.wav -D 0 -d 0

BR,

Xiaocong

0 Kudos

905 Views
deexithamba
Contributor III

Hello,

I had tried the same way even then the output remains the same!! To make it clear, following are the logs;

evk_8mq:/proc/asound/card0 # ls
id pcm0p
evk_8mq:/proc/asound/card0 # cat id
wm8524audio

evk_8mq:/proc/asound/card0 # tinyplay /storage/emulated/0/Download/testw1.wav -D 0 -d 0
Unable to open PCM device 0 (cannot set hw params: Invalid argument)

Regards,

Deexith 

0 Kudos

905 Views
diegoadrian
NXP Employee
NXP Employee

Hello,

The WM8524 audio codec is used on iMX8M EVK, this codec is very simple, it supports less feature. From the error log "cannot set hw params: Invalid argument", it shows tinyplay had set unsupported parameters to the driver.

 

From driver code, sound\soc\fsl\imx-wm8524.c, the driver only supports ".hw_params" interface, no other controller interface. You can add debug code to find, is there an error in function imx_hifi_hw_params().

Furthermore, can you please share the complete log that you have? I need it to see what exactly is causing the problem.

Best Regards,

Diego.

0 Kudos