Anti-aliasing doesn't work on i.MX6 OpenGL

cancel
Showing results for 
Search instead for 
Did you mean: 

Anti-aliasing doesn't work on i.MX6 OpenGL

223 Views
frankchenmh
Contributor III

Hi,

I am developing OpenGL application on i.MX6 with L3.0.35_4.0.0 Linux BSP and its Vivante GPU lib. I have ported QT 4.8.5 with OpenGL enabled. Basically I can run the OpenGL QT application. But when I try to draw lines I found the line anti-aliasing doesn't work.

The code for anti-aliasing is as follows:

            ......

            glBlendFunc(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA);
            glEnable(GL_BLEND);
            glEnable(GL_POINT_SMOOTH);
            glHint(GL_POINT_SMOOTH_HINT, GL_NICEST);
            glEnable(GL_LINE_SMOOTH);
            glHint(GL_LINE_SMOOTH_HINT, GL_NICEST);

            ......
The code worked if I test on Windows PC. But on i.MX6 it didn't take any effect for line anti-aliasing.

Any help apprecaited. Thanks!

0 Kudos
2 Replies

76 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hi Frank

I suggest to upgrade to Linux 4.14.78, where the vivante driver works.

i.MX Software | NXP 

Regards

0 Kudos

76 Views
frankchenmh
Contributor III

Hi,

Sorry for my late reply. I was on holiday in recent days.

It will take me much effort to upgrade Linux to 4.14.78. The board was designed by our company and have done many BSP porting work on it. Could you please let me know if the anti-aliasing is a known issue or not on L3.0.35_4.0.0? I am not able to find any ducument or source code to address this issue on this BSP. Thanks.

0 Kudos