A Burning question for IMX6Q

cancel
Showing results for 
Search instead for 
Did you mean: 

A Burning question for IMX6Q

226 Views
zhangzhiyong1
Contributor III

Hi,I used IMX6Q on my board,I can`t succeed in downloading Linux.to EMMC.

I use the MFGtools show me The USB change from HID-comlpliant device to mass storage device.then It Constantly display the mass storage device off and on.the log (Please See attached file MFGtool-0412.log).

My board with one MCIMX6Q6AVT10AD,four MT41K128M16JT-125K(total 1GB),and one MTFC8GLDEA-4M IT(8G)

My refer board with one MCIMX6Q5AVT10AC,four MT41K128M16JT-125K(total 1GB),and one KLM8G1WE4A-A001(8G)

How do I fix this? Thank you。

Best Regards!

Original Attachment has been moved to: MfgTool_0412.log.zip

Labels (2)
0 Kudos
1 Reply

128 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi zhangzhiyong 

just for test one can try to re-connect the usb cable to see if

mass storage device appears. Try to test mass storage test using linux and imx-test (../mxc_usb_test)

imx-test
www.nxp.com/lgfiles/NMG/MAD/YOCTO/imx-test-5.7.tar.gz

Check with oscilloscope signals USB_OTG_ID,USB_OTG_VBUS,VDDUSB

and compare its wavefroms with good board.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos