7ULP power_mode_switch not building with IAR

cancel
Showing results for 
Search instead for 
Did you mean: 

7ULP power_mode_switch not building with IAR

Jump to solution
601 Views
GuillaumeAudirac
NXP Employee
NXP Employee

Hi,

I downloaded the EVK SDK for the i.MX7ULP (SDK_2.7.0_EVK-MCIMX7ULP.zip). I currently build the power_mode_switch example with cmake as it seems to fail when using IAR.

Do you know any reason for that?

I am using the IAR IDE 8.11.1.13272 and it fails on some preprocessing error directives:

#error intrinsics.h is already included previously!

Is this just an issue with the SDK package?

Thanks.

Guillaume Audirac
Labels (1)
Tags (1)
0 Kudos
1 Solution
500 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Guillaume

reason may be old IAR version as described in Release Notes,

I tried with IAR 8.20 it builds fine

pastedImage_1.jpg

pastedImage_2.jpg

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

2 Replies
501 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Guillaume

reason may be old IAR version as described in Release Notes,

I tried with IAR 8.20 it builds fine

pastedImage_1.jpg

pastedImage_2.jpg

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

500 Views
GuillaumeAudirac
NXP Employee
NXP Employee

You are absolutely right. I had not checked as it was working fine for other examples.

Thanks a lot!

Guillaume Audirac
0 Kudos