3.14.28-1.0.0ga : Can't build meta-toolchain-qt5

cancel
Showing results for 
Search instead for 
Did you mean: 

3.14.28-1.0.0ga : Can't build meta-toolchain-qt5

Jump to solution
1,745 Views
yannickc
Contributor I

Dear all,

On the new BSP release I can't acheive to build a toolchain for qt5. There at least two problems :

1- The git server used by qt recipes is down and replace by git://code.qt.io (already done in meta-qt5 DIZZY HEAD)

2- There is a conflict between bluez4 (layer in poky) and bluez5 (in meta-fsl-bsp-release) and i don't know how to resolve it. It seems that qtsystem use bluez4 but I don't know who needs bluez5.

When I build with a clean environment (imx6qsabresd) I have this error :

ERROR: Multiple .bb files are due to be built which each provide virtual/bluez (/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/sources/poky/meta/recipes-connectivity/bluez/bluez4_4.101.bb /home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/sources/meta-fsl-bsp-release/imx/meta-fsl-bluez/recipes-connectivity/bluez5/bluez5_5.25.bb).

This usually means one provides something the other doesn't and should.

NOTE: Executing SetScene Tasks

NOTE: Executing RunQueue Tasks

ERROR: The recipe bluez4 is trying to install files into a shared area when those files already exist. Those files and their manifest location are:

   /home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/pkgdata/runtime/libasound-module-bluez

Matched in manifest-imx6qsabresd-bluez5.packagedata

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/pkgdata/runtime/libasound-module-bluez.packaged

Matched in manifest-imx6qsabresd-bluez5.packagedata

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/pkgdata/runtime-reverse/libasound-module-bluez

Matched in manifest-imx6qsabresd-bluez5.packagedata

Please verify which recipe should provide the above files.

The build has stopped as continuing in this scenario WILL break things, if not now, possibly in the future (we've seen builds fail several months later). If the system knew how to recover from this automatically it would however there are several different scenarios which can result in this and we don't know which one this is. It may be you have switched providers of something like virtual/kernel (e.g. from linux-yocto to linux-yocto-dev), in that case you need to execute the clean task for both recipes and it will resolve this error. It may be you changed DISTRO_FEATURES from systemd to udev or vice versa. Cleaning those recipes should again resolve this error however switching DISTRO_FEATURES on an existing build directory is not supported, you should really clean out tmp and rebuild (reusing sstate should be safe). It could be the overlapping files detected are harmless in which case adding them to SSTATE_DUPWHITELIST may be the correct solution. It could also be your build is including two different conflicting versions of things (e.g. bluez 4 and bluez 5 and the correct solution for that would be to resolve the conflict. If in doubt, please ask on the mailing list, sharing the error and filelist above.

ERROR: If the above message is too much, the simpler version is you're advised to wipe out tmp and rebuild (reusing sstate is fine). That will likely fix things in most (but not all) cases.

ERROR: Function failed: sstate_task_postfunc

ERROR: Logfile of failure stored in: /home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/bluez4/4.101-r11/temp/log.do_packagedata.15281

ERROR: Task 1738 (/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/sources/poky/meta/recipes-connectivity/bluez/bluez4_4.101.bb, do_packagedata) failed with exit code '1'

ERROR: The recipe bluez4 is trying to install files into a shared area when those files already exist. Those files and their manifest location are:

   /home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/lib/udev/hid2hci

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/lib/libbluetooth.la

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/lib/libbluetooth.so.3

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/lib/libbluetooth.so

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/lib/pkgconfig/bluez.pc

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/bluetooth.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/rfcomm.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/hci_lib.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/hidp.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/cmtp.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/hci.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/sdp.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/sco.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/l2cap.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/sdp_lib.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/usr/include/bluetooth/bnep.h

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/sysroots/imx6qsabresd/sysroot-providers/virtual_bluez

Matched in manifest-imx6qsabresd-bluez5.populate_sysroot

Please verify which recipe should provide the above files.

The build has stopped as continuing in this scenario WILL break things, if not now, possibly in the future (we've seen builds fail several months later). If the system knew how to recover from this automatically it would however there are several different scenarios which can result in this and we don't know which one this is. It may be you have switched providers of something like virtual/kernel (e.g. from linux-yocto to linux-yocto-dev), in that case you need to execute the clean task for both recipes and it will resolve this error. It may be you changed DISTRO_FEATURES from systemd to udev or vice versa. Cleaning those recipes should again resolve this error however switching DISTRO_FEATURES on an existing build directory is not supported, you should really clean out tmp and rebuild (reusing sstate should be safe). It could be the overlapping files detected are harmless in which case adding them to SSTATE_DUPWHITELIST may be the correct solution. It could also be your build is including two different conflicting versions of things (e.g. bluez 4 and bluez 5 and the correct solution for that would be to resolve the conflict. If in doubt, please ask on the mailing list, sharing the error and filelist above.

ERROR: If the above message is too much, the simpler version is you're advised to wipe out tmp and rebuild (reusing sstate is fine). That will likely fix things in most (but not all) cases.

ERROR: Function failed: sstate_task_postfunc

ERROR: Logfile of failure stored in: /home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/build_imx6qsabresd/tmp/work/cortexa9hf-vfp-neon-poky-linux-gnueabi/bluez4/4.101-r11/temp/log.do_populate_sysroot.15282

ERROR: Task 1733 (/home/user/Projets/VTX/VTX_BASE/LINUX/BSP_3.14.28-1.0.0-ga/sources/poky/meta/recipes-connectivity/bluez/bluez4_4.101.bb, do_populate_sysroot) failed with exit code '1'

Don't hesitate to mail me if you need more info.

Best,

Yannick

Labels (3)
0 Kudos
1 Solution
146 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello yannickc

There were some problems with the qt recipes but these are now fixed. Please do a repo sync and try again. I was able to successfully bake meta-toolchain-qt5.

Thanks for pointing out this error!

Please let us know if you continue having problems!

View solution in original post

0 Kudos
3 Replies
146 Views
alejandroacosta
Contributor I

Hi gusarambula‌, i have same problem, you could can help me please, this is error for get meta-toolchain-qt5:

Build Configuration:
BB_VERSION        = "1.30.0"
BUILD_SYS         = "x86_64-linux"
NATIVELSBSTRING   = "Ubuntu-16.04"
TARGET_SYS        = "arm-poky-linux-gnueabi"
MACHINE           = "imx6solosabreauto"
DISTRO            = "fsl-imx-x11"
DISTRO_VERSION    = "4.1.15-2.0.1"
TUNE_FEATURES     = "arm armv7a vfp  neon        callconvention-hard        cortexa9"
TARGET_FPU        = "hard"
meta              
meta-poky         = "HEAD:f5da2a5913319ad6ac2141438ba1aa17576326ab"
meta-oe           
meta-multimedia   = "HEAD:247b1267bbe95719cd4877d2d3cfbaf2a2f4865a"
meta-fsl-arm      = "HEAD:be78894e4682f111575470fb23e51e6ba523508d"
meta-fsl-arm-extra = "HEAD:3dfb82fc7e703eae9891b3ffda0e9393701f2396"
meta-fsl-demos    = "HEAD:a165068f8a0d1cf29aabe4b4053f28be1c2aa492"
meta-bsp          
meta-sdk          = "HEAD:90399d99af8a2660ebe50b49752e95b210239fd9"
meta-browser      = "HEAD:77736988073a5d90fcff9d0005c8477332ede387"
meta-gnome        
meta-networking   
meta-python       
meta-filesystems  = "HEAD:247b1267bbe95719cd4877d2d3cfbaf2a2f4865a"
meta-qt5          = "HEAD:ccae79be69c5268df3b47e4e14cea0591c39a531"

NOTE: Preparing RunQueue
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: libical-2.0.0-r0 do_populate_sysroot: QA Issue: libical.pc failed sanity test (tmpdir) in path /home/qt/Escritorio/var-imx-krogoth/build/tmp/work/cortexa9hf-neon-poky-linux-gnueabi/libical/2.0.0-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
ERROR: libical-2.0.0-r0 do_populate_sysroot: QA staging was broken by the package built above
ERROR: libical-2.0.0-r0 do_populate_sysroot: Function failed: do_qa_staging
ERROR: Logfile of failure stored in: /home/qt/Escritorio/var-imx-krogoth/build/tmp/work/cortexa9hf-neon-poky-linux-gnueabi/libical/2.0.0-r0/temp/log.do_populate_sysroot.20568
ERROR: Task 3278 (/home/qt/Escritorio/var-imx-krogoth/sources/poky/meta/recipes-support/libical/libical_2.0.0.bb, do_populate_sysroot) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1114 tasks of which 1088 didn't need to be rerun and 1 failed.
Waiting for 0 running tasks to finish:

Summary: 1 task failed:
  /home/qt/Escritorio/var-imx-krogoth/sources/poky/meta/recipes-support/libical/libical_2.0.0.bb, do_populate_sysroot
Summary: There was 1 WARNING message shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

I hope you can help me please, regards.

0 Kudos
147 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello yannickc

There were some problems with the qt recipes but these are now fixed. Please do a repo sync and try again. I was able to successfully bake meta-toolchain-qt5.

Thanks for pointing out this error!

Please let us know if you continue having problems!

View solution in original post

0 Kudos
146 Views
gusarambula
NXP TechSupport
NXP TechSupport

I reproduced this issue and I'm investigating the root cause. Hopefully someone may shed some light on this issue. Thanks for bringing this up, Yannick!

0 Kudos