Manufacture Mode issue on imx8QM MEK board

cancel
Showing results for 
Search instead for 
Did you mean: 

Manufacture Mode issue on imx8QM MEK board

Manufacture Mode issue on imx8QM MEK board

For imx8QM, The manufacture mode is supported on SD2 which is powered by LDO2 of PMIC2 on MEK board.

LDO2 of PMIC2 on MEK board is OFF by default. (LDO2 of PMIC1 is on by default)

So manufacture mode is NOT working on the imx8QM MEK board.

the solution would be:

1. schematic change

Exchange the power supply(VCC_LDO_SD) and USDHC_VSELECT signal of SD2 and SD1.

between PMIC2 (U23) and PMIC 1(U10).

so that, the VCC_LDO_SD2) and USDHC2_VSELECT will be located on where VCC_LDO_SD1) and USDHC1_VSELECT are origonally. 

and VCC_LDO_SD1 and USDHC1_VSELECT will be located on where VCC_LDO_SD2) and USDHC2_VSELECT are origonally. 

SD1 will no longer be supported as the boot resource, instead SD2 will be.

anyway you still can connect a WIFI to SD1 , becasue the power supply can be turned on after software booting up.SD2.png

SD1.png

2. Modify the default fuse of PMIC, whcih is to enable LDO2 of PMIC2 by default.

    please contact your local FAE and Sales for this. 

we may add notification in the reference schematic and HW development guild in the future.

Comments

Good information. Thanks for sharing

 

mobdro

But isn't there also a boot ROM bug (see https://community.nxp.com/message/984764#comment-988006) which prevents usage of MFG mode on the i.MX 8? Or did this magically get fixed already?

So to summarize, does MFG mode truly work? Can somebody please confirm who has really seen this working!

Hi Alfred ,

    How can I change PIMC fuse to enable LDO2 output ? can you share it out ?

Version history
Revision #:
1 of 1
Last update:
‎11-05-2018 10:24 PM
Updated by: