How to Test Yocto for i.MX6

cancel
Showing results for 
Search instead for 
Did you mean: 

How to Test Yocto for i.MX6

How to Test Yocto for i.MX6

Join FSL-community-bsp project: https://lists.yoctoproject.org/listinfo/meta-freescale

In order to test Yocto Project for i.MX6 or any other supported board please follow the instructions pointed by FSL Community BSP.

In order to download the source code, please follow this instructions FSL Community BSP.

With the downloaded source code, you can follow the steps from this training: Yocto Training - HOME

If you face a problem, please, send an email to https://lists.yoctoproject.org/listinfo/meta-freescale

This page made sense when there was not other tutorial to point people on how to download and build the very first image using Yocto Project tools for i.MX family boards. Today, FSL Community BSP has become a complete environment with its own landing page (FSL Community BSP) and a collaborative community around meta-freescale mailing list. I encourage you to register in meta-freescale mailing list.

I configured this document to be closed for new comments. In case of any issue or bug, please, send an email to meta-freescale.

Comments

Somehow all they baking and bake.
But do not know how the cake is to eat :smileycool:

Hi,there

     Can anyone tell me how to get through the error message of "http://docbook.sourceforge.net/release/xsl/current/eclipse/eclipse3.xsl can't be loaded" while issuing "make DOC=adt-manual"

     My government blocked sourceforge away and I tried to download those projects in mirrorsites lacked in compilation. But for above message, I just don't know which project I should download for? I tried to download release,xsl, but failed to get correct file of eclipse3.xsl.

Hello Daiane !!

We bought a Sabre lite MCIMX6Q-SL from farnell (SABRE Lite i.MX6 Platform element14’s i.MX 6Quad Processor Evaluation Board  - element14) . We followed all yours steps, but we  only  got  kernel panics every single time (we used several images!). However after a week of hard working we deliberated that danny branch doesn't work for this sabre lite. We asked in many post i( yocto, element14 ... )providing feedbacks.  Finally the conclusion is :  if you want to use this board is better to compile the dylan branch! Please see below:


Yocto and IMX 6 Element14 devlopment kit  - element14

http://www.element14.com/community/thread/26340?start=0&tstart=0

It would be great if you can add a few words( when you explain how to download the BSP source) saying that we can download the dylan branch.(https://wiki.yoctoproject.org/wiki/Releases).

Thank you for  this post and your time!!

Diego,

Apologize for this! This great tutorial made by DaianeAngolini was create in the old and dark ages when danny was the stable branch. Now with Yocto 1.4, dylan is the one to choose. The document has been corrected. Hope you can advance faster in your project!

Leo

LeonardoSandovalGonzalez is right, controlhorus, it's a very old document.

For sabre lite help, please take a look on comments of this doc https://community.freescale.com/docs/DOC-94989

If you fell like, please, enter meta-freescale mail list: https://lists.yoctoproject.org/listinfo/meta-freescale

I just took a look at the freescale-community-bsp-platform repository on Github, and it looks like Something Has Happened.  Apparently the recommended branch name is now 'dora'.  Has the latest and greatest Official Freescale goodness dropped yet?  Can we move up to a new kernel?

Hi Leo,

We've been testing it and so far it looks great!

So everything builds just fine for the SabreSD and I am now ready to start hacking on my own BSP, layers, etc.  My only problem is I can't find the code for u-boot.  Patching the kernel is great, but that's not the first step in cloning a platform.  Where is u-boot?

All code is located under tmp/work, search on that folder. I just baked, and u-boot is on this path:

tmp/work/imx6qsabresd-poky-linux-gnueabi/u-boot-fslc/v2013.10-r0/git/

The u-boot in my build tree is u-boot-imx, not u-boot-fslc.  I used the recipe to see where to manually pull the source from and I placed it into the "git" folder, but it does not exist anywhere else in the build tree.

  • build@ubuntu:/media/i.MX6_ddr3/fsl-community-bsp/build.x11/tmp/work$ find . -iname mx6qsabresd.c
  • ./imx6qsabresd-poky-linux-gnueabi/u-boot-imx/2013-04-5/git/uboot-imx/board/freescale/mx6qsabresd/mx6qsabresd.c
  • build@ubuntu:/media/i.MX6_ddr3/fsl-community-bsp/build.x11/tmp/work$

If you are modifying the mx6qsabresd.c file, you should create a patch first, then either modifying the current recipe to add the patch OR create a .bbappend file in a new layer. The second option is better because it does not affect a working recipe.

Leo

Our board is a modified clone of the SD.  My normal process for building u-boot for a new platform is to create a new directory under board/freescale, copy the sd files into it, and then modify them.  Then I copy/rename the sd header file in include/configs to our board name and modify it.  My problem is I can’t do any of this because it doesn’t exist.  The source isn’t in the build tree.

It would be better if you post your question in a separate thread, including detail steps and your modified u-boot recipe.

Yes, please sbl, create a new thread and detail your environment,

Please, share or mention me.

Do you know this doc? https://community.freescale.com/docs/DOC-94849

After typing "bitbake fsl-image-test" i get

WARNING: Failed to fetch URL ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz, attempting MIRRORS if available

How can i change

ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz

to

https://gnome-build-stage-1.googlecode.com/files/uuid-1.6.2.tar.gz

Try this on your local.conf

MIRRORS =+ " \

${FSL_MIRROR}  https://gnome-build-stage-1.googlecode.com \n \

"

And take a look on this link (as you having a lot of fetch error due to your proxy):

https://www.yoctoproject.org/docs/current/poky-ref-manual/poky-ref-manual.html#idm425008

and

https://www.yoctoproject.org/docs/current/poky-ref-manual/poky-ref-manual.html#idm425008/pre

Hope it helps

Daiane Angolini, thank you for reply.

Do you mean <yocto_root>/build/conf/local.conf ?

Since I post this issue i have learnt to fix this errors by editing *.bb files in <yocto_root>/source folder.

You sollution is much more better and i will try it when i will get next error or warning message from installer.

But it looks like "https://.." mirrors cause error messages in Yocto. Are you sure that it will be working?

I have no fetch error due to my proxy. I mean that it is alright with them. Link ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz is really unreachable.

But thanks for link to Yocto reference manual.

I think that image will be work despite to this warning messages. Is it?

And i have new warnings. Can you say something about this?

WARNING: QA Issue: lttng-modules: Files/directories were installed but not shipped

  /lib

  /lib/modules

  /lib/modules/3.0.35-1.1.0+yocto+g21304e1

  /lib/modules/3.0.35-1.1.0+yocto+g21304e1/kernel

  /lib/modules/3.0.35-1.1.0+yocto+g21304e1/kernel/lttng-modules

WARNING: File '/unit_tests/memtool' from imx-test was already stripped, this will prevent future debugging!

WARNING: debianutils: No generic license file exists for: SMAIL_GPL in any provider

Excuse me for bad English.

Regards.

See my reply made bold within your text

aleksandr Muraviov wrote:

Daiane Angolini, thank you for reply.

Do you mean <yocto_root>/build/conf/local.conf ?

Yes

Since I post this issue i have learnt to fix this errors by editing *.bb files in <yocto_root>/source folder.

You sollution is much more better and i will try it when i will get next error or warning message from installer.

But it looks like "https://.." mirrors cause error messages in Yocto. Are you sure that it will be working?


I have never tested if myself. And I´m not sure i would be able to *really* test it since I don´t have a proxy like yours..... But I think we can rely on yocto documentation. The more difficult would know the exactly mirror URL to use.


I have no fetch error due to my proxy. I mean that it is alright with them. Link ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz is really unreachable.

But thanks for link to Yocto reference manual.




Other thing to "trick" yocto would download the same package googling web for it, and copy the tar.gz into downloads folder (and create a file with exactly same filename and .done at end (for exemple uuid-1.6.2.tar.gz.done) in order to make bitbake believe it was already downloaded.

Offcourse it´s not ideal, but may give you some time....



I think that image will be work despite to this warning messages. Is it?

And i have new warnings. Can you say something about this?

The messages says you built those files and did not installed anywhere. It makes you think if you´re missing something or you´re really avoiding those files.

And other things you don´t have control, like memtool being already stripped

WARNING: QA Issue: lttng-modules: Files/directories were installed but not shipped

  /lib

  /lib/modules

  /lib/modules/3.0.35-1.1.0+yocto+g21304e1

  /lib/modules/3.0.35-1.1.0+yocto+g21304e1/kernel

  /lib/modules/3.0.35-1.1.0+yocto+g21304e1/kernel/lttng-modules

WARNING: File '/unit_tests/memtool' from imx-test was already stripped, this will prevent future debugging!

WARNING: debianutils: No generic license file exists for: SMAIL_GPL in any provider

Excuse me for bad English.

My english is bad too. Don´t worry

I´m from Brazil. Where are you from?

Regards.

I am using imx6 Sabre ARD and yocto and trying to get the touch working. I enabled the 3M in the kernal configuration and disabled all other touches. I receive an error in usbtouchscreen

Daiane Angolini, thank you for reply.


>> I have never tested if myself. And I´m not sure i would be able to *really* test it since I don´t have a proxy like yours..... But I think we can rely on yocto documentation. The more difficult would know the exactly mirror URL to use.

I tried it and it does not work for me. I get some python syntax error. I can not post it here. May be i dona something wrong. I think it is no matter.

I use "old, kind" edit *.dd files and it work for me.


>> Other thing to "trick" yocto would download the same package googling web for it, and copy the tar.gz into downloads folder (and create a file with exactly same filename and .done at end (for exemple uuid-1.6.2.tar.gz.done) in order to make bitbake believe it was already downloaded.

Sounds great.


>>The messages says you built those files and did not installed anywhere. It makes you think if you´re missing something or you´re really avoiding those files.

>> And other things you don´t have control, like memtool being already stripped.


I am so sorry, but i not really undestand what are you speaking about. I think it is no metter because it is just warning messages. Is it?

I´m from Brazil. Where are you from?


It is great! Maybe sometime I will travel there. I'm from Russia. Here is cold(

Please, create a new topic with your error message and some other information people can try to debug.

Feel free to mention me.

>>>I am so sorry, but i not really undestand what are you speaking about. I think it is no metter because it is just warning messages. Is it?


Yes :smileywink:



>>>It is great! Maybe sometime I will travel there. I'm from Russia. Here is cold(

Next year we have fifa world cup :smileygrin:


I think taht it is not so important. Images working. It is great.

But i have some issue with network subsystem. When i build target fsl-image-gui i can not make it working (i mean networking).

When kernel starting I get

Configuring network interfaces... eth0: Freescale FEC PHY driver [Generic PHY] (mii_bus:phy_addr=1:00, irq=-1)

udhcpc (v1.20.2) started

Sending discover...

PHY: 1:00 - Link is Up - 100/Full

net eth0: FEC ENET: rcv is not +last

Sending discover...

Sending discover...

No lease, failing

Starting rpcbind daemon...rpcbind: cannot create socket for udp6

rpcbind: cannot create socket for tcp6

done.

And then if i type

root@imx6qsabresd:~# udhcpc -i eth0 -n

I get

udhcpc (v1.20.2) started

Sending discover...

Sending discover...

Sending discover...

net eth0: FEC ENET: rcv is not +last

No lease, failing

root@imx6qsabresd:~#

Once i was able to connect to my board via ssh. But in shart time connection was refused.

So i can not get lease from my dhcp. If i use static ip and netmask network not working too. Sometime i get messages like this:


net eth0: FEC ENET: rcv is not +last

net eth0: FEC ENET: rcv is not +last

net eth0: FEC ENET: rcv is not +last

net eth0: FEC ENET: rcv is not +last

net eth0: FEC ENET: rcv is not +last

net eth0: FEC ENET: rcv is not +last

net eth0: FEC ENET: rcv is not +last

net eth0: FEC ENET: rcv is not +last

net eth0: FEC ENET: rcv is not +last

Regards.

Almost forgot:

root@imx6qsabresd:~# uname -a

Linux imx6qsabresd 3.0.35-1.1.0+yocto+g21304e1 #1 SMP PREEMPT Wed Oct 9 17:15:15 MSK 2013 armv7l GNU/Linux

My board is MCIMX6Q-SDP SCH-27392 REV C3 700-27392 REV B.

Oh! I saw your email for meta-freescale! I prefer reply you there.

Thank you wery much, Daiane. I'm very much obliged to you.

Hi OtavioSalvador,

     When I test Tocto Ubuntu 10.04,

sudo apt-get install gawk wget git-core diffstat unzip texinfo \

     build-essential chrpath libsdl1.2-dev xterm



Download repo. It will help you to download the source code:

cd rootfs_builder

curl https://dl-ssl.google.com/dl/googlesource/git-repo/repo > ./repo

chmod a+x ./repo

Download the BSP source:

cd rootfs_builder

./repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b dylan

fatal: git 1.7.2 or later required?

how to solve this problem,want to install others libs?

Thanks.

Yes; it is.

First I'd advise you to use a newer OS version. For Ubuntu I'd suggest 12.04 (and for Debian, my preference, I'd use 7.2).

In case your cannot update your system, you can follow the link:

http://www.yoctoproject.org/docs/1.5/ref-manual/ref-manual.html#required-git-tar-and-python-versions

Which explains how to install the 'buildtools' tarball and use it in an older system.

Regarding the fsl-community-bsp branch, please use 'dora' as 'dylan' is not the current stable release and dora has nice new improvements :-)

Regards,

Hi Otaviosalvador,

   I try to test Yocto i.mx6. After

  repo sync

  vi conf/local.conf for example:

MACHINE ??= 'imx6qsabrelite'

DISTRO ?= 'poky'

PACKAGE_CLASSES ?= "package_rpm"

EXTRA_IMAGE_FEATURES = "debug-tweaks"

USER_CLASSES ?= "buildstats image-mklibs image-prelink"

PATCHRESOLVE = "noop"

CONF_VERSION = "1"

BB_NUMBER_THREADS = '8'

PARALLEL_MAKE = '-j 8'

ACCEPT_FSL_EULA = "1"

then run command:

bitbake core-image-minimal

This command run long time, but my computer power down unfortunately.

When I turn on my computer again,run this command bitbake core-image-minimal,

The program 'bitbake' is currently not installed.

You can install it by typing:

sudo apt-get install bitbake

Can you help me? I don't the reason.

Thanks.

Hello Lion,

after reboot Your computer or open a new terminal you must do

  • source ./setup-environment build

Why Your computer turned off could be based on Energy saving options. You should check that for the next bitbake

Joerg

You most probably is out of memory or similar; in either case you must to run the setup-environment script again as explained by Joerg-SH.

Joerg,Otaviosalvador,

      Thank you. bitbake core-image-minimal success;I want to play video,how to  build Qt-x11 with gstreamer by Yocto?

Regards,

hi,  did you find the issues sorted even i am receiving an error in usbtouchscreen

i have built qte-in-use-image and i have the linux running successfully and i am getting the smarthome demo now i want a root@imx6qsabre: and login to run the demo qt example as well as my own qt code but how do i get that login after samrthome demo. kindly help me with this?

You can get the login using the serial console conected to the board.

Hi people

I have built the image as described above but I am surprised by the size of the image in sda1.

I had imagined it would be much smaller

A full distribution install would only be 12Gigs

Any comments???

wayne@AMILO-2727:~/fsl-community-bsp/build/tmp/deploy/images/imx6dlsabresd$ df -h

Filesystem      Size  Used Avail Use% Mounted on

/dev/sda1       457G   57G  378G  13% /

none            4.0K     0  4.0K   0% /sys/fs/cgroup

udev            995M  4.0K  995M   1% /dev

tmpfs           201M  1.1M  200M   1% /run

none            5.0M     0  5.0M   0% /run/lock

none           1004M   15M  990M   2% /run/shm

none            100M   96K  100M   1% /run/user

wayne@AMILO-2727:~/fsl-community-bsp/build/tmp/deploy/images/imx6dlsabresd$

Thanks

Wayne

I don't get your point, wayne

What is the problem?

df is a terrible tool for measuring the size of your install (except maybe on the target system).  What you're seeing reflected in that 57G figure is:

  • Each final image repeated three times (once as a .tar.bz2 archive, once as an ext3 filesystem image, and once as a .sdcard block image),
  • All the source code files,
  • All the build products (.o files and such),
  • All the build tools,
  • Cached copies of the distribution archives and/or source repositories for all of the above (yes, entire Git repositories with full history get cloned -- all kinds of fun when it comes time to build the kernel),
  • The rest of your Linux installation.

So, yeah.  That figure is not a big surprise.

This guide is not actual now! At least this link doesn't work "curl https://dl-ssl.google.com/dl/googlesource/git-repo/repo > ./repo". Please, update it to the latest version. Thanks a lot!

Konstantin Kovalev wrote:

This guide is not actual now! At least this link doesn't work "curl https://dl-ssl.google.com/dl/googlesource/git-repo/repo > ./repo". Please, update it to the latest version. Thanks a lot!

You noticed that, too.  Here's what we're using now:

curl http://commondatastorage.googleapis.com/git-repo-downloads/repo > ./repo

Thanks for your quick response! It works!

P.S. Daiane, could you please rewrite this line "curl https://dl-ssl.google.com/dl/googlesource/git-repo/repo > ./repo"  in your main post to the correct one "curl http://commondatastorage.googleapis.com/git-repo-downloads/repo > ./repo". I guess that it will be really helpful... Thanks in advance!

In fact, I would like to remove this DOC and update all the others to the latest cmds.

There is no sense to have the same step-by-step duplicated in several files

Version history
Revision #:
1 of 1
Last update:
‎11-28-2012 10:40 AM
Updated by: