Enable mbedTLS 2.4.0 on i.MX6UL SDK2.2

cancel
Showing results for 
Search instead for 
Did you mean: 

Enable mbedTLS 2.4.0 on i.MX6UL SDK2.2

Enable mbedTLS 2.4.0 on i.MX6UL SDK2.2

The attched package includes mbedTLS and CAAM driver based on SDK2.2, you can apply it on Windows Installer: MCUXpresso SDK2.2 for i.MX 6UltraLite

1. fsl_caam.c and fsl_caam.h under devices\MCIMX6G3\drivers is CAAM driver.

2. Some files under middleware\mbedtls-2.4.0\port\sdk are porting code for mbedTLS

3. Example codes are under folder boards\evkmcimx6ul which have driver example and mbedTLS example.

4, The patch package only support IAR toolchain.

5, Due to SDK don't support allocation of non-cachable memory dynamically, so some static non-cachable bufferes in sdk_mbedtls.c is used for shared memory with hareware. So mbedTLS don't be used for multi-thread concurrently.

Attachments
Version history
Revision #:
1 of 1
Last update:
‎07-04-2017 07:47 PM
Updated by: