Building QT for i.MX6

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Building QT for i.MX6

Building QT for i.MX6

The build is verified on prebuilt rootfs(based on LTIB) which can be downloaded from

EGL uses framebuffer backend -> ->


1. Download the git respository for qt4.8:

$ git clone qt
$ cd qt

Let us consider this as <QTDir>

2. Create /tftpboot and point your target fileystem. As like

$ mkdir -p /tftpboot

$ cd /tftpboot

$ ln -s $(ROOTFFS) rootfs

TBD:Need to work on this to use sysroot option

3. Create a build directory to install for the qt4 packages. This directory can be  in any location. For example,

$ mkdir /opt/qt4
$ sudo chown -R <username> /opt/qt4

Let us consider the the <installdir> as /opt/qt4

4. Extract the attached mkspecs(linux-imx6-g++.tar.gz) to  <QTDir>/mkspecs/qws/

5. Apply the attached cd 0001-add-i.MX6-EGL-support.patch attached to enable egl support for i.MX6

$ cd <QTDir>
$ patch -p1<0001-add-i.MX6-EGL-support.patch

6. Export CROSS-COMPILE location path to PATH

$ export PATH=$PATH:/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/

7. Enter to the <QTDir>. Do configure. You can select the options as you like. Here is an example

$ cd <QTDir>

$ ./configure -qpa -arch arm -xplatform qws/linux-imx6-g++ -no-largefile -no-accessibility \
-opensource -verbose -system-libpng -system-libjpeg -system-freetype -fast -opengl es2 -egl -confirm-license \
-qt-zlib  -qt-libpng  -no-webkit -no-multimedia \
-make examples -make demos \
-release -make libs -exceptions -no-qt3support -prefix <installdir>

8. When the configure summary is shown make sure the Qt has OpenGL ES 2.0 support. Do build

$ make
$ make install

9. Now need to build eglfs plugin

$ cd <QTDir>/src/plugins/platforms/eglfs
$ make
$ make install

    Now the eglfs will be installed to the QT Install directory.

10. By now all required QT files are in <install directory>

11. Copy the install directory to target filesystem

$ cp -rf /opt/qt4 /tftpboot/rootfs/opt/.

12. Running Qt apps on target
    - Boot the target either with NFS or SD Image
    - Ensure that folder <installdir> is copied on target file system at “/usr/local”.
    - Launch application using

$ cd /opt/qt4/examples/opengl/hellogl_es2
$ ./hellogl_es2 -platform eglfs


These steps are performed on the host

1. Download the git respository for qt5:

$ git clone git:// qt5

$ cd qt5

    Let us consider this as <QTDir>

2. Create a build directory to install for the qt5 packages. This directory can be  in any loctation. For example,

$ sudo mkdir /opt/qt5

$ sudo chown -R <username> /opt/qt5

Let us consider the the installdir as /opt/qt5

3. Enter the Qt5 directory and run the init-repository script to download all the source code for
   Qt5. To download all the source code will take about an hour.

$ ./init-repository

Update:  In the latest Qt5 release the webkit library is included by default and there are some issues trying to compile it.

use the next line to avoid problems if not desired to use webkit.

$ ./init-repository --no-webkit

4. From the following path

$ gedit qtbase/mkspecs/devices/linux-imx6-g++/qmake.conf

5. At the top of the qmake.conf, there is a configure line. Copy and paste the configure line into a text file located
   in your build build directory. Edit the configure line to find your toolchain and filesystem. Also make sure to
   include the options -no-pch, -no-opengl, -opengl es2, Here is an example of
   a configure line.

Update: In the latest Qt5 stable, the option to compile the examples/demos is -compile-examples, instead of -make examples -make demos

If you are running into problems with webkit,  use the option -no-icu, this will disable the webkit.

$ cd <QTDir>
$ cd qtbase
$ ./configure -v -opensource -confirm-license -no-pch -no-xcb -no-opengl -opengl es2  \
        -make libs -device imx6 \
       -compile-examples \
      -device-option CROSS_COMPILE=/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/arm-fsl-linux-gnueabi- \
       -sysroot <rootfs> -no-gcc-sysroot \
      -prefix <installdir>

7. Make the textfile that has the configure line and executable and run it. When the configure summary is shown make sure the Qt5 has openGL ES 2.0 support. Do build

$ make
$ sudo make install

   When Qt5 has finished building, Qt5 will be installed in two places:

           1. <location of rootfs>/<installdir>
           2. <HOST Machine>/<install dir>

This is good because now all the libraries and binaries for Qt5 are installed on the host and the target filesystem. Therefore, the target already has all the libraries and  binaries needed to run Qt5.

8. Also need to build qtjsbackend and qtdeclarative.

$ cd <location to Qt5 git>
$ cd qtjsbackend
$ ../qtbase/bin/qmake -r
$ make && sudo make install

$ cd <location to Qt5 git>
$ cd qtdeclarative
$ ../qtbase/bin/qmake -r
$ make && sudo sudo make install

9. Running Qt apps on target
    - Boot the target either with NFS or SD Image
    - Ensure that folder <installdir> is copied on target file system at “/usr/local”.
    - Launch application using

$ cd /opt/qt5/examples/opengl/hellowindow
$ ./hellowindow -platform eglfs

On the target file system, the location of target libaries and includes may present in arm-linux-gnueabi directory. Make sure to create soflinks to QT can find. For example

$ cd $(ROOTFS)/usr/lib
$ ln -s arm-linux-gnueabi/

While building QT5, you may see a build error that is not found. This might be some problem to be addressed in QT. Workaround is to
copy all the binaries to correct path as like this

$ cp  <ROOTFS>/<installdir>/lib/* <HOST Machine>/<installdir>/.

What is coming up next:
1. QT on X is already available on Yocto filesystem. Steps to enable GPU Acceleration TDB.
2. QT with Wayland support.

Labels (1)

First: I'm a very beginner in developing software for Linux Embedded. So may be my questions

are very basic. I'm sorry for that.

I need to cross-compile a QT 5 program from a PC based Ubuntu system to a i.MX6 board.

I already built the O.S. for the board following the instructions of the page


Now I'm trying to set up QT following the

document, i.e. this page.

I did step 1, 2, 3 and 4.

At step 5 gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12 is referenced.

Where can I find it?

I looked for it on site but I didn't find it.


As I noticed that there is a patch file 0001-add-i.MX6-EGL-support.patch for Qt 4.8, however, there is not such a patch for QT5.

Did you miss it? There might be a similar patch to Qt5.

As I tried the hellowindow application in Qt 5.1, I got error log as follow. Do you have any hints?

</opengl/hellowindow$ ./hellowindow  -platform eglfs

QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv_open failed

QIconvCodec::convertToUnicode: using Latin-1 for conversion, iconv_open failed

QEglFSImx6Hooks will set environment variable FB_MULTI_BUFFER=2 to enable double buffering and vsync.

If this is not desired, you can override this via: export QT_EGLFS_IMX6_NO_FB_MULTI_BUFFER=1

EGLFS: Unable to query physical screen size, defaulting to 100 dpi.


EGLFS: OpenGL windows cannot be mixed with others.


Hi, xicai chen.

I have the same problem with hellowindow application in Qt 5 (EGLFS: OpenGL windows cannot be mixed with others)
You solved it?

I would suggest everyone who uses already YOCTO for their images to also use it to compile Qt

See for a working Qt5 tutorial here:

Everyone who doesn't use YOCTO not 'til now: DO IT :smileygrin: read more about it in the Yocto Training - HOME

If you want to use Qt4, you can do this even easier because of the different layers that YOCTO delivers...

for the board: qt-in-use-image or qte-in-use-image

as toolchain: meta-toolchain-qt or meta-toolchain-qte

Have fun!


I solved that issue.

It would be a good choice to comment out those code which reports “EGLFS: OpenGL windows cannot be mixed with others”, that would make it fine.

Kind regards

Richard Chen

Hello Bradley,

I'm starting with IMX6 and Qt.

I followed the instructions but I'm having the same issue as yours. I have the same directories after the install, nothing more, and some errors during "make" and "make install".

Did you find a solution to build Qt4.8 for the IMX6?


Hey I am experimenting with Yocto and my Mx6 Board. I am using dora and I used qte-in-use-image to "bake" an image. I want to experiment with QT + OpenGL using the framebuffer.

I disable X11 and Wayland with the flag: DISTRO_FEATURES_remove = "x11 wayland" on my local.conf

I am able to run the vivante vdk examples but I have not being able to run the hellogl_es2 example from OpenGL. I get a pitch black rendering. Have you being able to run the OpenGL examples from QT?

AFAIK the qt-in-use-image only produces a rootfs for Qt 4.8 - but still the version should be good enough to compile the hellogl_es2 example.

I tried to compile the application with my Qt 5.1.1 toolchain (see link in my previous comment) but it didn't work - gnu/stubs-soft.h wasn't found... I didn't recognize this error before and don't know how to handle this - so sorry, I cant help you with that :smileysad:

I found out that the hellogl_es2 example is not able to run when you dont have X11 or wayland. You need a windowing system because the hellogl_es2 encapsulates an QGLWidget within another widget. Better is to use QT5 + QML. I will give it a try. And probably your error is because you have to edit the file qtbase/mkspecs/devices/linux-imx6-g++/qmake.conf and add -mfloat-abi=hard in IMX6_CFLAGS. Give it a try.


I successfully installed qt 4.8 in my target.

Initially i had 4.6.0 on my target, which had audio demo codes. 4.8 doesn't seem to have any multimedia demos. The existing examples execute correctly. however any example which i used to

run in 4.6.0 using qws doesn't seem to execute on 4.8. It crashes with a "segmentation fault".

I have qtCreater 2.7.2  with Qt 4.8.4 on my host, and any example code for instance a system call code or a mmap call doesn't seem to work.

I had shifted to 4.8 assuming and expecting better audio and Serial communication support. but simple codes compiled do not work in ltib. It is very frustrating.

Can anyone please help me out with that.



I am trying to setup a cross compiler setup for the RIOT (IMX6) on opensuse 13.21 (64),  as I would like to use qt with qws under Ubuntu Image (Must still figure out how-to disable the GUI, as this is not a 'standard' Unbuntu startup)

Step 6 assumes one has a cross compiler already installed.

    export PATH=$PATH:/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/

How can I install this,  where can I download it, as it seem to 'included' in some BSD package.


I'm building qt-5.1.1 from dora branch of yocto project. All fine works instead HTML5 video from simple browser in qtwebkit-examples

I see player controls, but it doesn't work. On some videos i can view freeze frame of videos, but it not playing.

In console gstreamer output messages like this:

Qt Warning: Could not find a location of the system's Compose files. Consider setting the QTCOMPOSE environment variable.

libpng warning: iCCP: Not recognizing known sRGB profile that has been edited

Received finished signal while progress is still: 10 Url:  QUrl( "" ) 

Aiur: 3.0.11

Core: MPEG4PARSER_06.07.04  build on Dec  5 2013 11:41:38

  mime: video/quicktime; audio/x-m4a; application/x-3gp

  file: /usr/lib/imx-mm/parser/

Content Info:








    Seekable  : Yes

    Size(byte): 32830110

Movie Info:

    Seekable  : Yes

    Live      : No

    Duration  : 0:11:52.503360000

    ReadMode  : Track

    Track     : 2

Track 00 [video_000000] Enabled

    Duration: 0:11:52.503360000

    Language: und


          video/x-h264, parsed=(boolean)true, width=(int)640, height=(int)360, framerate=(


Track 01 [audio_000000] Enabled

    Duration: 0:11:52.503360000

    Language: und


          audio/mpeg, mpegversion=(int)4, channels=(int)2, rate=(int)44100, bitrate=(int)9

          6000, framed=(boolean)true, stream-format=(string)raw, codec_data=(buffer)121000


Beep: 3.0.11

Core: AAC decoder Wrapper  build on Jan 22 2014 15:42:53

  mime: audio/mpeg, mpegversion=(int){2,4}

  file: /usr/lib/imx-mm/audio-codec/wrap/

CODEC: BLN_MAD-MMCODECS_AACD_ARM_03.07.00_CORTEX-A8  build on Sep 18 2013 10:29:53.

[--->FINALIZE aiurdemux

QtMultimedia examples working correctly.

Whats wrong and how can I fix it?

Hi all, i'm trying to build qt5 for a udoo quad board (use imx6 quad but i'm blocked at ./configure. i had some errors :

/home/modjo/Udoo/Qt5_build/fsl-linaro-toolchain/arm-fsl-linux-gnueabi/bin/g++ -c -pipe -march=armv7-a -mfpu=neon -DLINUX=1 -DEGL_API_FB=1 -mfloat-abi=softfp -g -Wall -W -fPIE -I../../mkspecs/devices/linux-imx6-g++ -I. -I../../../../usr/include -I../../../../usr/bin -o arch.o arch.cpp
g++: error trying to exec 'cc1plus': execvp: No such file or directory
Messages de l'assembleur:
Erreur fatale: option -march= invalide: « armv7-a »
gmake: *** [arch.o] Erreur 1
Unable to determine architecture!

Could not determine the target architecture!
Turn on verbose messaging (-v) to see the final report.
Determining architecture... ()
g++ -c -pipe -g -Wall -W -fPIE -I../../mkspecs/linux-g++ -I. -o arch.o arch.cpp
g++ -o arch arch.o
Found architecture in binary
System architecture: 'unknown'
Host architecture: 'i386'
C++11 auto-detection... ()
/home/modjo/Udoo/Qt5_build/fsl-linaro-toolchain/arm-fsl-linux-gnueabi/bin/g++ -c -pipe -march=armv7-a -mfpu=neon -DLINUX=1 -DEGL_API_FB=1 -mfloat-abi=softfp -O2 -std=c++0x -Wall -W -fPIE -I../../../mkspecs/devices/linux-imx6-g++ -I. -I/home/modjo/Udoo/Qt5_build/usr/include -I/home/modjo/Udoo/Qt5_build/usr/bin -o c++11.o c++11.cpp
g++: error trying to exec 'cc1plus': execvp: No such file or directory
Messages de l'assembleur:
Erreur fatale: option -march= invalide: « armv7-a »
gmake: *** [c++11.o] Erreur 1
C++11 disabled.





OpenGL ES 2.x auto-detection... ()
/home/modjo/Udoo/Qt5_build/fsl-linaro-toolchain/arm-fsl-linux-gnueabi/bin/g++ -c -pipe -march=armv7-a -mfpu=neon -DLINUX=1 -DEGL_API_FB=1 -mfloat-abi=softfp -O2 -Wall -W -fPIE -I../../../mkspecs/devices/linux-imx6-g++ -I. -I/home/modjo/Udoo/Qt5_build/usr/include/GLES2 -I/home/modjo/Udoo/Qt5_build/usr/include -I/home/modjo/Udoo/Qt5_build/usr/bin -o opengles2.o opengles2.cpp
g++: error trying to exec 'cc1plus': execvp: No such file or directory
Messages de l'assembleur:
Erreur fatale: option -march= invalide: « armv7-a »
gmake: *** [opengles2.o] Erreur 1
OpenGL ES 2.x disabled.
The OpenGL ES 2.0 functionality test failed!
You might need to modify the include and library search paths by editing

For information the Udoobuntu file system :

the link for the tutorial :

my qmake.conf :



EGLFS_PLATFORM_HOOKS_SOURCES = $$PWD/qeglfshooks_imx6.cpp

QMAKE_INCDIR          += $${ROOTFS_PATH}/usr/include $${ROOTFS_PATH}/usr/bin
QMAKE_LIBDIR          += $${ROOTFS_PATH}/usr/lib/arm-linux-gnueabihf $${ROOTFS_PATH}/usr/lib

QMAKE_INCDIR_OPENGL_ES2 += /home/modjo/Udoo/Qt5_build/usr/include/GLES2
QMAKE_LIBDIR_OPENGL_ES2 += /home/modjo/Udoo/Qt5_build/usr/lib/GLESv2

#QMAKE_LIBS_EGL        += /home/modjo/Udoo/Qt5_build/usr/lib/GLESv2
#QMAKE_LIBS_OPENGL_ES2  += /home/modjo/Udoo/Qt5_build/usr/lib/GLESv2
#QMAKE_LIBS_OPENVG      += /home/modjo/Udoo/Qt5_build/usr/lib/OpenVG

QMAKE_LIBS_EGL        += -lEGL

QMAKE_LFLAGS          += -Wl,-rpath-link,$$/home/modjo/Udoo/Qt5_build/lib/arm-linux-gnueabihf

IMX6_CFLAGS            = -march=armv7-a -mfpu=neon -DLINUX=1 -DEGL_API_FB=1



and my configure :

./configure -prefix /opt/qt5 -make libs -no-pch -no-opengl -device imx6 -device-option CROSS_COMPILE=/home/modjo/Udoo/Qt5_build/fsl-linaro-toolchain/arm-fsl-linux-gnueabi/bin/ -no-largefile -opengl es2 -qt-zlib -qt-libpng -qt-libjpeg -no-nis -no-cups -gui -make examples -sysroot /home/modjo/Udoo/Qt5_build/exemples -no-gcc-sysroot -opensource -confirm-license -qreal float -v

Do you an idea to resolve this ?

Hi ,

I successfully cross compiled QT5 for my custom iMX6Q board,

I used LTIB 3.0.35_4.1.0 kernel for building my u-boot, kernel and rootfs.

I am attaching documents and links that i prepared to help anyone who

wishes to build QT5, it might not help you directly, but the procedure

should help you.



Ok nishad, i'm waiting for your procedure ! thank's in advance !

Configuration Script:

./configure -v -opensource -confirm-license -no-sse2 -no-sse3 -no-ssse3

-no-sse4.1 -no-sse4.2 -no-avx -no-xcb -no-sql-mysql -no-sql-db2

-no-sql-ibase -no-sql-oci -no-sql-odbc -no-sql-tds -no-sql-sqlite2

-no-pch -no-opengl -opengl es2  -wayland -make libs -device imx6 -make

examples -device-option


-sysroot /home/sumeet/ltib/rootfs -no-gcc-sysroot -prefix /usr/local/QT_5

Link to be followed thoughtfully along with the procedure given on the

current link above:

I used the "cross-compiled-tools" to compile QT-5

and built individual modules using the link.

you need to download it as use it taking reference of the script given below for setting up path.

Cleaning a_config_if_compile_wrong:

sudo git submodule foreach --recursive "git clean -dfx"

Script for_setting_paths:

./fixQualifiedLibraryPaths /home/sumeet/ltib/rootfs


You might get fontconfig errors, which you need to solve by analysing

the error.

Although i was able to install QT5 , i still have problems with fonts, i

am not able to see fonts in the GUI. i am working on it.



Hi all,

I tried build qt5 like in this doc.

My configuration command is:

./configure -v -opensource -confirm-license -make libs -device imx6  -device-option CROSS_COMPILE=/home/x0158990/hdd/tools/poky/1.7/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-  -sysroot /home/x0158990/hdd/tools/poky/1.7/sysroots/x86_64-pokysdk-linux -no-gcc-sysroot  -prefix /home/x0158990/work/tools/QT5

I have got error:

Precompiled-headers support enabled.

/home/x0158990/hdd/tools/poky/1.7/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-g++ -c -fvisibility=hidden fvisibility.c

Symbol visibility control enabled.

/home/x0158990/hdd/tools/poky/1.7/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-g++ -o -shared -Wl,-Bsymbolic-functions -fPIC bsymbolic_functions.c

bsymbolic_functions.c:2:2: error: #error "Symbolic function binding on this architecture may be broken, disabling it (see QTBUG-36129)."

#error "Symbolic function binding on this architecture may be broken, disabling it (see QTBUG-36129)."


Symbolic function binding disabled.

In QTBUG-36129 bug's description I didn't found applicable solution.

Please help!

HI nice tutorial.... can you pls give some insights about qt webkit as well how to render a fullscreen HTML5 based webpage using that... am really new to qt... pls guide me


I have successfully build Qt4.8 for imx6. But when I tried to run the sample example I got the below error:

"Could not create the egl surface: error = 0x300b"

Please help me out of this.




Sorry for the delay in reply,

Could you give me more information about your problem?

Are you using LTIB to build your image or Yocto?

Did you manually build the QT?

Also can you mail me your configuration script? There could be a possibility that the QT is not properly built.



Hi Nishad,

Thanks for replying.

I am using LTIB for building my image.

yes, I built QT4.8 manually with steps as mentioned on this page.

Also, the configuration script is same as given here.

./configure -qpa -arch arm -xplatform qws/linux-imx6-g++ -no-largefile -no-accessibility \

-opensource -verbose -system-libpng -system-libjpeg -system-freetype -fast -opengl es2 -egl -confirm-license \

-qt-zlib  -qt-libpng  -no-webkit -no-multimedia \

-make examples -make demos \

-release -make libs -exceptions -no-qt3support -prefix /opt/qt4.


Paritosh Singh

These patches are for Qt4 not for Qt5 right?

Hi all PrabhuSundararaj

The git url  "git:// qt5"  is not work.

Is it new git url  for qt5 ? Because I want to use LTIB porting Qt5.

Please help, thanks all.

Hello All,

is anyone able to compile QT5.5 or QT 5.6 for imx6q. This page is not helping me much because QT 5 compilation section referring the gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12 fsl tool chain whcih is not available for download because it is pretty quite old.If i am using linaro latest tolchain 4.8 or 4.7 QT doesn't compile.

I would really appreciate if someone let me know which is the correct tool-chain to compile QT 5.5 or QT 5.6 version on imx6.

Hi nishad

I have successfully build Qt4.8.5 for imx6. But when I tried to run the sample example I got the below error:

root@freescale /opt/qt4.8.5-arm-opengl$ cd examples/opengl/hellogl_es2/

root@freescale /opt/qt4.8.5-arm-opengl/examples/opengl/hellogl_es2$ ls

bubble.cpp       glwidget.h       main.cpp         texture.qrc

bubble.h         hellogl_es2      mainwindow.cpp

glwidget.cpp  mainwindow.h

<-opengl/examples/opengl/hellogl_es2$ ./hellogl_es2                    

bubble.cpp       glwidget.h       main.cpp         texture.qrc

bubble.h         hellogl_es2      mainwindow.cpp  

glwidget.cpp  mainwindow.h    

<-opengl/examples/opengl/hellogl_es2$ ./hellogl_es2 -platform eglfs

Segmentation fault

root@freescale /opt/qt4.8.5-arm-opengl/examples/opengl/hellogl_es2$

Hi All

I have QT5.5.0, i want to crosscompile into imx6-linux. So i used the following configuration

./configure -v -opensource -confirm-license -no-pch -no-xcb -no-opengl -opengl es2  \

        -make libs -device imx6 \

       -compile-examples \

      -device-option CROSS_COMPILE=/opt/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/arm-fsl-linux-gnueabi- \

       -sysroot /home/zumi/Project/Imx6q/rootfs/L3.0.35_4.1.0_130816_images_MX6/Rootfs/opt/qt -no-gcc-sysroot \

      -prefix /opt/qt-vision

Following error i am getting,

cc1plus: error: unrecognized command line option '-fuse-ld=gold'

arm-fsl-linux-gnueabi-g++ -o -shared -Wl,-Bsymbolic-functions -fPIC bsymbolic_functions.c

bsymbolic_functions.c:2:2: error: #error "Symbolic function binding on this architecture may be broken, disabling it (see QTBUG-36129)."

Symbolic function binding disabled.

And one more thing,

QT5.5.0 didn't have qws.conf file. so in your attached qmake.conf file i remove include(../../common/qws.conf) line.

If i not remove the line it shows No such a file found error. After the removing i got the above mentioned error.



Hi aravinthkumar jayaprakasam,

You can try to copy the qws.conf on qt4,

then put the qws.conf into qt-everywhere-opensource-src-x.x.x/qtbase/mkspecs/common/  (x.x.x is your qt version).

Then configure again.

Hi peterchiu

in Qt 5.5 don't have qws. And also above mentioned problem i solved.



Hello every one,

How to configure and build Qt5.5 for INTEGRITY RTOS???

Hi bharathadwajakodanda​,

In your Qt source Below location can you select which device  you want to use:


After that i will give you the support.

Hi aravinth,

Yeah, you got my point. There is no target device platform for INTEGRITY in


Is there any possibility to create target platform in


by our own??

This is the full command I used to configure the target

configure -embedded -xplatform qws/integrity-arm-cxarm -prefix /


-embedded - builds the embedded version of Qt

-xplatform qws/integrity-arm-cxarm - selects the arm-cxarm mkspec for


-qt-sql-sqlite - links sqlite directly into the Qt library

According to my task the target should be integrity-arm-cxarm

On Fri, Aug 12, 2016 at 7:50 AM, aravinthkumar jayaprakasam <


Post you query in Qt Form. They will give support.

Home | Qt Forum



I already done with it.

On Fri, Aug 12, 2016 at 10:43 AM, aravinthkumarjayaprakasam <

No ratings
Version history
Last update:
‎02-11-2013 10:29 AM
Updated by: