Build Ubuntu For i.MX8 Series Platform

cancel
Showing results for 
Search instead for 
Did you mean: 

Build Ubuntu For i.MX8 Series Platform

No ratings

Build Ubuntu For i.MX8 Series Platform

The Guide is how to use Ubuntu filesystem with i.MX8 series platform.At present, I had try it on i.MX8QXP with 4.14.98 kernel with ubuntu16.04.

The Document will be continuously updated with enable VPU, ubuntu18.04. The desktop we can chose Gnome or weston.  Because driver 

support issue, gc7000 series gpu not support render Gnome destop but it can render weston destop. 

Update 2019/7/31:

Ubuntu-i.MX8-weston.pdf  

Feature:

  • weston + ubuntu18.04 + 4.14.98 kernel
  • VPU (enable with gplay or gst-play) 
  • GPU (could render desktop and run GPU demo under root privileges on Weston Desktop)

I also try ubuntu with gnome desktop, ubuntu18.04 can not run gnome, need use ubuntu19.04. But Gnome Desktop just render by CPU. 

-------------------------------------------------------------------------------------

Update 2020/3/6:

Ubuntu-i.MX8M.pdf

Just a simple guide for IMX8M series, will be  continuously updated. 

Tags (1)
Attachments
Comments

Hi Gnar Fang,

       Thanks for the doc. Yes, i verified and added galcore module to auto load on startup. But unfortunately i am still not getting the desktop with the following error:

sudo -E weston --tty=1
Date: 2019-04-11 UTC
[17:00:10.607] weston 5.0.0
https://wayland.freedesktop.org
Bug reports to: https://gitlab.freedesktop.org/wayland/weston/issues/
Build: 5.0.0-33-gfb563901 MGS-4627 [#ccc] weston will turn off when panel-psotion=none and use gplay (2019-03-14 11:30:30 +0800)
[17:00:10.607] Command line: weston --tty=1
[17:00:10.607] OS: Linux, 4.19.35-1.1.0+g0f9917c56d59, #1 SMP PREEMPT Wed Oct 30 13:54:51 UTC 2019, aarch64
[17:00:10.608] warning: XDG_RUNTIME_DIR "/run/user/1001" is not configured
correctly. Unix access mode must be 0700 (current mode is 700),
and must be owned by the user (current owner is UID 1001).
Refer to your distribution on how to get it, or
http://www.freedesktop.org/wiki/Specifications/basedir-spec
on how to implement it.
[17:00:10.608] Starting with no config file.
[17:00:10.608] Output repaint window is 16 ms maximum.
[17:00:10.608] Loading module '/usr/lib/libweston-5/drm-backend.so'
[17:00:10.612] initializing drm backend
[17:00:10.614] using /dev/dri/card0
[17:00:10.614] DRM: supports universal planes
[17:00:10.614] DRM: supports atomic modesetting
[17:00:10.614] DRM: supports picture aspect ratio
[17:00:10.614] Loading module '/usr/lib/libweston-5/gl-renderer.so'
[17:00:10.626] EGL client extensions: EGL_EXT_client_extensions
EGL_EXT_platform_base EGL_KHR_platform_wayland
EGL_EXT_platform_wayland EGL_KHR_platform_gbm
[17:00:10.627] warning: neither EGL_EXT_swap_buffers_with_damage or EGL_KHR_swap_buffers_with_damage is supported. Performance could be affected.
[17:00:10.627] EGL_KHR_surfaceless_context available
[17:00:10.627] failed to create context
[17:00:10.627] EGL error state: EGL_BAD_ALLOC (0x3003)
[17:00:10.627] EGL error state: EGL_SUCCESS (0x3000)
[17:00:10.627] failed to initialize egl
Segmentation fault

Hi Gnar Fang,

            If i run weston --use-pixman then there is no issue with the display. This means HW acceleration is not working. This is due to the OpenGL ES driver issue or we need to enable HW acceleration during weston compilatio? Thanks

Hi,

The issue is look like below.

1.warning: XDG_RUNTIME_DIR "/run/user/1001" is not configured correctly. Unix access mode must be 0700 (current mode is 700), and must be owned by the user (current owner is UID 1001).

2.[17:00:10.627] EGL error state: EGL_BAD_ALLOC (0x3003)
[17:00:10.627] EGL error state: EGL_SUCCESS (0x3000)
[17:00:10.627] failed to initialize egl

You can try it.

$ sudo su

XDG_RUNTIME_DIR =/run/user/1001

$ weston --tty=1

It is sure that need to enable HW acceleration during weston compilatio. which the config parameter in build weston? same as my guide?

Hi Gnar Fang,

              My apologies for the late reply. Yes, i did use the arguments as per the documents to build Weston/Wayland. Regarding the rUNTIME_DIR whatever the ownership/permission i change the warning message continues to exist. Thanks

Hi , I am not sure why cause it.  you can check if there are /usr/lib/aarch64-xx  libGLES, libEGL。if so, delete them.

Hi prashanth:
   How do you get this desktop? After I run "sudo -E weston --tty = 1", the displayed desktop is just the same as the yocto-wayland desktop. Does your system have apt-get install some software?

 

Tks~

HI :

yes, It' yocto-wayland desktop. If you want other desktop , you can try apt-get to install .

江亚强

软件工程师

Shenzhen Huameishi Technology Co., Ltd

深圳市华美视科技有限公司

深圳市南山区科苑路6号科技园工业大厦605

Tel:0755-26037882-616

Mail:yaqiang.jiang@huameishi.com

Hi,Gnar Fang

Whether the GPU cannot be enabled as long as the Ubuntu file system is used?

It guide is support use GPU when running Ubuntu file system

In Ubuntu-i.MX8M.pdf ,I did not build weston in step 7 and I apt-get install lxqt.Use lxqt as the display desktop.I get follow results:

pastedImage_1.png

I have successfully loaded the gpu driver,But why no application uses gpu.When I do not use ubuntu filesyste,I get follow results:

galcore-last.png

have 26 apps uses gpu.

Please help me answer,thanks,have a nice day!

Hi,  

our GPU is support wayland only.

You should try build the desktop with source code and enable xwayland.

how to enable xwayland in lxqt.I can install gnome-wayland only.In lxqt desktopNo xwayland related configuration options.

you can refernce the yocto script to build xwayland.  

But I am not sure if you use LXQT could use GPU, The best way,

you should build LXQT source code with our gpu driver instead of apt-get LXQT directly.

Hi Gnar,

I want weston auto load on device startup, where can I add weston --tty=1?

Refere to the yocto's  weston.ini file.

Version history
Revision #:
1 of 1
Last update:
‎07-19-2019 12:09 AM
Updated by: