iMX6 xwayland compilation error - drm library

cancel
Showing results for 
Search instead for 
Did you mean: 

iMX6 xwayland compilation error - drm library

637 Views
ericholmberg
Contributor III
When trying to compile imx-5.4.70-2.3.0 for iMX6QD, I'm getting a missing drm library issue in the qtwayland recipe.
 
I thought it might have been https://bugreports.qt.io/browse/QTBUG-83303, but the patches for that (https://codereview.qt-project.org/c/qt/qtwayland/+/281699) have already been integrated.
 
Any ideas?
 
 
mkdir imx-yocto-bsp
cd imx-yocto-bsp
repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-zeus -m imx-5.4.70-2.3.0.xml
repo sync -j8

DISTRO=fsl-imx-xwayland MACHINE=imx6qsabresd source imx-setup-release.sh -b build-xwayland
bitbake imx-image-full

 

After about 14 hours, it fails with the following message:

ERROR: qtwayland-5.15.0+gitAUTOINC+0f847b7688-r0 do_configure: Error calling /home/builder/imx-yocto-bsp/build-wayland/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/recipe-sysroot-native/usr/bin/qmake -makefile -o Makefile QT_BUILD_PARTS-=examples QT_BUILD_PARTS-=tests /home/builder/imx-yocto-bsp/build-wayland/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/git/qtwayland.pro -- -no-feature-wayland-brcm -feature-wayland-client -no-feature-wayland-drm-egl-server-buffer -feature-wayland-egl -no-feature-wayland-libhybris-egl-server-buffer -feature-wayland-server -no-feature-xcomposite-egl -no-feature-xcomposite-glx
ERROR: qtwayland-5.15.0+gitAUTOINC+0f847b7688-r0 do_configure: Execution of '/home/builder/imx-yocto-bsp/build-wayland/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/temp/run.do_configure.6315' failed with exit code 1:

Running configuration tests...
Project ERROR: Test config.qtwayland_client.tests.dmabuf-server-buffer tries to use undeclared library 'drm'
WARNING: exit code 1 from a shell command.

ERROR: Logfile of failure stored in: /home/builder/imx-yocto-bsp/build-xwayland/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/temp/log.do_configure.6315

 

0 Kudos
7 Replies

629 Views
ericholmberg
Contributor III

Looks like it is a missing bitbake dependency issue.  Re-running to build command every time it fails allows it to eventually compile successfully.

 

308 Views
Raxesh-Oriya
Contributor III

Hi @ericholmberg,

I have very similar issue while compiling for imx7ulp. Could you please elaborate on "Re-running to build command every time it fails allows it to eventually compile successfully"

0 Kudos

295 Views
ericholmberg
Contributor III

I have very similar issue while compiling for imx7ulp. Could you please elaborate on"Re-running to build command every time it fails allows it to eventually compile successfully"

Literally just run it a couple of times.  Since bitbake is running multiple builds in parallel, eventually the missing dependency will be built and the build will be successful.  If you get to the point where only the failing package is running, then you need to stop and fix the problem because the loop isn't going to make any further progress.  I just did the following as a brute-force method to get on with development.

# Hacky way until it is successful.  There is probably a status code
# returned that could be used to do a more elegant script.
while true
do
bitbake imx-image-full
done

 

0 Kudos

285 Views
amberworth
Contributor III

Have you tried using 

bitbake imx-image-full -k

 -k, --continue        Continue as much as possible after an error. While the
                       target that failed and anything depending on it cannot
                       be built, as much as possible will be built before
                       stopping.

 

0 Kudos

263 Views
Raxesh-Oriya
Contributor III

Hi @amberworth,

-k did not work for me.

 

bitbake imx-image-full -k
Loading cache: 100% |#########################################################################################################| Time: 0:00:00
Loaded 4640 entries from dependency cache.
Parsing recipes: 100% |#######################################################################################################| Time: 0:00:01
Parsing of 3218 .bb files complete (3217 cached, 1 parsed). 4641 targets, 485 skipped, 1 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies

Build Configuration:
BB_VERSION           = "1.44.0"
BUILD_SYS            = "x86_64-linux"
NATIVELSBSTRING      = "ubuntu-18.04"
TARGET_SYS           = "arm-poky-linux-gnueabi"
MACHINE              = "imx7ulpevk"
DISTRO               = "fsl-imx-wayland"
DISTRO_VERSION       = "5.4-zeus"
TUNE_FEATURES        = "arm vfp cortexa7 neon thumb callconvention-hard"
TARGET_FPU           = "hard"
meta                 
meta-poky            = "HEAD:d88d62c20d7d8da85f02edb170dae0280624ad7e"
meta-oe              
meta-multimedia      
meta-python          = "HEAD:2b5dd1eb81cd08bc065bc76125f2856e9383e98b"
meta-freescale       = "HEAD:14f1a630a47375432f93c556927b879b51d84c4e"
meta-freescale-3rdparty = "HEAD:dbcc686f52c3c84db8cb86aa8973a4e373651b98"
meta-freescale-distro = "HEAD:ca27d12e4964d1336e662bcc60184bbff526c857"
meta-bsp             
meta-sdk             
meta-ml              = "HEAD:63665ab70ca609451533101cded2a620b340768c"
meta-nxp-demo-experience = "HEAD:c7263d9f3cc7bbf44e7164ffeda494cf283d3dec"
meta-browser         = "HEAD:ee3be3b5986a4aa0e73df2204a625ae1fe5df37e"
meta-rust            = "HEAD:53bfa324891966a2daf5d36dc13d4a43725aebed"
meta-clang           = "HEAD:711e593d5984aad3bf35c51b7ac4482982bc16c7"
meta-gnome           
meta-networking      
meta-filesystems     = "HEAD:2b5dd1eb81cd08bc065bc76125f2856e9383e98b"
meta-qt5             = "HEAD:21ce4c124d9a972d9122f87c64ac2773bf04c284"
meta-python2         = "HEAD:4400f9155ec193d028208cf0c66aeed2ba2b00ab"

Initialising tasks: 100% |####################################################################################################| Time: 0:00:05
Sstate summary: Wanted 14 Found 0 Missed 14 Current 2758 (0% match, 99% complete)
NOTE: Executing Tasks
NOTE: Setscene tasks completed
ERROR: qtwayland-5.15.0+gitAUTOINC+0f847b7688-r0 do_configure: Error calling /home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/recipe-sysroot-native/usr/bin/qmake -makefile -o Makefile    QT_BUILD_PARTS-=examples QT_BUILD_PARTS-=tests   /home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/git/qtwayland.pro  --   -no-feature-wayland-brcm -feature-wayland-client -no-feature-wayland-drm-egl-server-buffer -feature-wayland-egl -no-feature-wayland-libhybris-egl-server-buffer -feature-wayland-server -no-feature-xcomposite-egl -no-feature-xcomposite-glx
ERROR: qtwayland-5.15.0+gitAUTOINC+0f847b7688-r0 do_configure: Execution of '/home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/temp/run.do_configure.18760' failed with exit code 1:

Running configuration tests...
Project ERROR: Test config.qtwayland_client.tests.dmabuf-server-buffer tries to use undeclared library 'drm'
WARNING: /home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/temp/run.do_configure.18760:1 exit 1 from 'exit 1'

ERROR: Logfile of failure stored in: /home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/temp/log.do_configure.18760
Log data follows:
| DEBUG: Executing shell function qmake5_base_preconfigure
| DEBUG: Shell function qmake5_base_preconfigure finished
| DEBUG: Executing shell function do_configure
| NOTE: qmake prevar substitution: ' QT_BUILD_PARTS-=examples QT_BUILD_PARTS-=tests '
| NOTE: qmake configure substitution: '  -no-feature-wayland-brcm -feature-wayland-client -no-feature-wayland-drm-egl-server-buffer -feature-wayland-egl -no-feature-wayland-libhybris-egl-server-buffer -feature-wayland-server -no-feature-xcomposite-egl -no-feature-xcomposite-glx'
| 
| Running configuration tests...
| Project ERROR: Test config.qtwayland_client.tests.dmabuf-server-buffer tries to use undeclared library 'drm'
| ERROR: Error calling /home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/recipe-sysroot-native/usr/bin/qmake -makefile -o Makefile    QT_BUILD_PARTS-=examples QT_BUILD_PARTS-=tests   /home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/git/qtwayland.pro  --   -no-feature-wayland-brcm -feature-wayland-client -no-feature-wayland-drm-egl-server-buffer -feature-wayland-egl -no-feature-wayland-libhybris-egl-server-buffer -feature-wayland-server -no-feature-xcomposite-egl -no-feature-xcomposite-glx
| WARNING: /home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/temp/run.do_configure.18760:1 exit 1 from 'exit 1'
| ERROR: Execution of '/home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/temp/run.do_configure.18760' failed with exit code 1:
| 
| Running configuration tests...
| Project ERROR: Test config.qtwayland_client.tests.dmabuf-server-buffer tries to use undeclared library 'drm'
| WARNING: /home/aws-oraxesh/imx-yocto-bsp-zeus/build/tmp/work/cortexa7t2hf-neon-mx7ulp-poky-linux-gnueabi/qtwayland/5.15.0+gitAUTOINC+0f847b7688-r0/temp/run.do_configure.18760:1 exit 1 from 'exit 1'
| 
ERROR: Task (/home/aws-oraxesh/imx-yocto-bsp-zeus/sources/meta-qt5/recipes-qt/qt5/qtwayland_git.bb:do_configure) failed with exit code '1'
NOTE: Tasks Summary: Attempted 7377 tasks of which 7376 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
  /home/aws-oraxesh/imx-yocto-bsp-zeus/sources/meta-qt5/recipes-qt/qt5/qtwayland_git.bb:do_configure
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

 

0 Kudos

250 Views
ericholmberg
Contributor III

Looks like the -k option worked since it built everything else, but you still have the drm lib issue.  Not sure what the difference is between your Yocto build and mine since running the build after this worked for me.

Double check the QT bug report https://bugreports.qt.io/browse/QTBUG-83303 and see if you can update the build config flags (devtool will be your friend, here).

0 Kudos

271 Views
ericholmberg
Contributor III

Yes, if that option works, then it would mean just running the build command twice.