CTSSkQPTestCases failures on Android P9.0.0_2.2.0 BSP for i.MX6 and SabreSD

cancel
Showing results for 
Search instead for 
Did you mean: 

CTSSkQPTestCases failures on Android P9.0.0_2.2.0 BSP for i.MX6 and SabreSD

Jump to solution
491 Views
brood
Contributor III

Greetings NXP Community!

I posted this question a while back on the general i.MX6 Processors forum - however I have not garnered any responses as of late.  This is kind of important, as there seems to be a bug or two in the 2D graphics drivers for the i.MX6Q (using Vivante GC2000 GPU) that are preventing the Android CTS tests from fully passing (this is a big deal!!).  Original post can be found here:

https://community.nxp.com/t5/i-MX-Processors/CTSSkQPTestCases-failures-on-Android-P9-0-0-2-2-0-BSP-f...

Here are the details:

I'm working on porting the Android P9.0.0_2.2.0 BSP to our tablet product that is based on the SabreSD i.MX6Q reference design and I'm running into the following failures in the Android CTS test suite, specifically the tests in the CtsSkQPTestCases module.  This module tests the SKIA graphics library, which to my understanding is tied into the graphics 2D functionality available on the i.MX6Q chip.  I know very little about GPUs/graphics in general, so I'm hoping someone has a solution to address the following failing CtsSkQPTestCases:

1. org.skia.skqp.SkQPRunner#gles_arithmode

2. org.skia.skqp.SkQPRunner#gles_colorwheel

3. org.skia.skqp.SkQPRunner#gles_cross_context_image

4. org.skia.skqp.SkQPRunner#gles_deferred_texture_image_medium_decoded

5. org.skia.skqp.SkQPRunner#gles_deferred_texture_image_medium_decoded_indexed

6. org.skia.skqp.SkQPRunner#gles_deferred_texture_image_medium_encoded

7. org.skia.skqp.SkQPRunner#gles_deferred_texture_image_medium_encoded_indexed

8. org.skia.skqp.SkQPRunner#gles_encode_srgb_png

9. org.skia.skqp.SkQPRunner#gles_flippity

10. org.skia.skqp.SkQPRunner#gles_image_from_yuv_textures

11. org.skia.skqp.SkQPRunner#gles_image_surface

12. org.skia.skqp.SkQPRunner#gles_imagemasksubset

13. org.skia.skqp.SkQPRunner#gles_makecolorspace

14. org.skia.skqp.SkQPRunner#gles_shadermaskfilter_image

15. org.skia.skqp.SkQPRunner#gles_tileimagefilter

16. org.skia.skqp.SkQPRunner#unitTest_GrMeshTest

Both the BSP for the SabreSD i.MX6Q and my tablet product are showing the same test case failures, so it's not a porting issue.  My hunch is a bug in the graphics driver, or other related component.  Poking through the external/skia repository shows that NXP made a change related to a potential issue with the graphics driver (NXP issue reference: MA-14657), so I'm thinking there's an outstanding bug that has yet to be fixed or provided.

Attached are the Android CTS test results for both the BSP on the SabreSD and my tablet product for reference.

Also tagging @LiuXuegang in this post as he made a commit in the 'external/skia' repository that explicitly states: "UI icons display abnormal on 6DQ boards with skiagl renderer, it is GPU driver issue still under debugging, force use Opengl es 2.0 instead of 3.0 to temp fix the issue on 6DQ boards."

0 Kudos
1 Solution
437 Views
IvanRuiz
NXP TechSupport
NXP TechSupport

A reply was already made to the corresponding case, let's continue the support there.

View solution in original post

0 Kudos
1 Reply
438 Views
IvanRuiz
NXP TechSupport
NXP TechSupport

A reply was already made to the corresponding case, let's continue the support there.

View solution in original post

0 Kudos