eAppApiPlmeSet set channel on JN5168

cancel
Showing results for 
Search instead for 
Did you mean: 

eAppApiPlmeSet set channel on JN5168

273 Views
Contributor II

Hi, I  want to change 5168 channel  during  working.I use eAppApiPlmeSet(PHY_PIB_ATTR_CURRENT_CHANNEL, channel)  to change channel,but I find that  it always fail or it will go to reboot.

Could you please tell me why ?

Thanks!

Labels (2)
9 Replies

51 Views
Contributor II

Hello,the previous phenomenon is error ,the phenomenon is that if I change the first channel now and next I change the second channel immediately. The 5168 Tx pin will always stay high,which I use spectrum analyzer to measure.But when I change the first channel and next I wait fifteen milliseconds to change the second channel,it will work normally.

Now my application requirements are accurate to the millisecond ,so I need 5168 to change channel quickly.

I want to know that do I miss any other steps? Thanks !

0 Kudos

51 Views
NXP TechSupport
NXP TechSupport

Hi,

What is the application note that you are working on?

Is the device connected to a wireless network?

Did you try to use the 802.15.4 example and you could use the beacon examples, without waiting for a beacon request and could send by all the channels. Also, you could customize the data that you are sending.

Regards,

Mario

0 Kudos

51 Views
Contributor II

Hello,my  application is that I need two channels to communicate with terminal equipment.One of channel is that use to broadcast to allocate working time for terminal equipment,and the other one use to exchange data with terminal equipment.The  terminal equipment working time is millisecond level,so I need change channel quickly.After this time, the Tx pin will always stay high.But if I delay a few ms,this problem don't appear. Did you have meet this problem?

Or did you give me the beacon examples? Thanks !

0 Kudos

51 Views
NXP TechSupport
NXP TechSupport

Hi,

I am checking the time that the eAppApiPlmeGet requires to set up the next channel.

However, you could look at the 802.15.4 examples that we provide. JN-AN-1174 Template

Regards,

Mario

0 Kudos

51 Views
Contributor II

Ok,I'm so sorry to bother  you.By the way,can you help me check the time that the eAppApiPlmeSet requires to set up the next channel if you can or any other way to change channel?

Thanks!

0 Kudos

51 Views
NXP TechSupport
NXP TechSupport

Hi,

I am sorry for the late response. I confirm with the validation team, and I get feedback from them.

Unfortunately, since the stabilization time will depend on the environment in which the network is operating, there's no fixed time define. So, in this case, 15ms that you are setting could be enough to stabilize the channel.

Sorry for any inconvenience that this may cause you.

Regards,

Mario

51 Views
Contributor II

ok ! Thank you very much.

0 Kudos

51 Views
Contributor II

Hello,it always return  PHY_ENUM_SUCCESS,and I use eAppApiPlmeGet  to get current channel,it returns the channel which I set.But when I send packet on this channel,I can't find this packet or 5168 will go to reboot.

I want to transmit different packet on different channel.

On 5148,this problem don't exist.

Before using this API,is any other things need me to do ?

Thanks ! 

0 Kudos

51 Views
NXP TechSupport
NXP TechSupport

Hi,

I hope you are doing great.

What is the return value that you are getting? How are you calling this API?

What is the application note that you are working on?

Please look at the next code and be sure if the device is getting a PHY_ENUM_SUCCESS

if (eAppApiPlmeSet(PHY_PIB_ATTR_CURRENT_CHANNEL, u8Channel) !=
PHY_ENUM_SUCCESS)
{
// Handle error;
}

Regards,

Mario

0 Kudos