Unable to receive Read Attribute response for IAS Zone Status in JN5189 coordinator

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to receive Read Attribute response for IAS Zone Status in JN5189 coordinator

292 Views
Contributor II

I am working with jn5189 as wireless connectivity zigbee coordinator (iot-control-bridge )and I am trying to read IAS zone status for an IAS device, but when ever I send a Read attribute request from the zgui tool I am receiving the following raw data " 1 81 0 0 c 7e 6 b1 5b 1 5 0 0 2 0 19 0 0 0 0 " in this RAW packet I don't see the zone status, but when I am checking the ZigBee sniffer I am seeing the the end node is receiving the read attribute request and giving a read attribute response with the current zone status. But I don't see that in the received RAW packet, can anyone tell why is this happening ?

Labels (2)
0 Kudos
5 Replies

101 Views
NXP TechSupport
NXP TechSupport

Hi Bharadwaj,

Is it possible that you could provide the sniffer log?

However, Could you please look at the APP_ZCL_cbEndpointCallback in the app_zcl_event_handler.c file?

The switch case is entering the case E_ZCL_CBET_READ_ATTRIBUTES_RESPONSE, but is not executing anything in your code.

Regards,

Mario

0 Kudos

101 Views
Contributor IV

Hi Mario, 

Please find the zigbee sniffer screen shot attached for your reference. 

We are using the control bridge application and have not done any modification.

According to which the read attribute must read the zone status.

Please help us in understanding the code.

Also in our code we find that , 

case E_ZCL_CBET_LOCK_MUTEX:
case E_ZCL_CBET_UNLOCK_MUTEX:
case E_ZCL_CBET_READ_ATTRIBUTES_RESPONSE:
case E_ZCL_CBET_READ_REQUEST:
case E_ZCL_CBET_TIMER:
case E_ZCL_CBET_ZIGBEE_EVENT:
//vLog_Printf(TRACE_ZCL, "EP EVT:No action\r\n");
break;

So what do we need to do.

Thank you,

Deepanraj.A

0 Kudos

101 Views
NXP TechSupport
NXP TechSupport

Hi Deepanraj Anbarasan,

I have been checking the issue that you are facing, the Control bridge is entering into the APP_ZCL_cbEndpointCallback and the case E_ZCL_CBET_READ_INDIVIDUAL_ATTRIBUTE_RESPONSE, in my case because I am reading just 1 attribute. So, it is reporting the status in the next part of the code.

app_zcl_event_handler.c

ZNC_BUF_U8_UPD  ( &au8LinkTxBuffer [u16Length],  psEvent->uMessage.sIndividualAttributeResponse.eAttributeStatus,    u16Length );

Regards,

Mario

0 Kudos

101 Views
Contributor IV

Hi Mario,

Yes, We are also reading only one attribute. How do we correct this part of the code.

Is there any change required to be done to get the read attribute response for the IAS zone.

Please let us know, We are new in this and not sure where the change is required.

Thank you,

Deepanraj.A

0 Kudos

101 Views
NXP TechSupport
NXP TechSupport

Hi Deepanraj,

I ran a simple test and the device is getting 2 attributes but the device is reading out with the individual attribute.

pastedImage_1.png

You could add your code in the case E_ZCL_CBET_READ_ATTRIBUTES_RESPONSE. Take as reference the E_ZCL_CBET_READ_INDIVIDUAL_ATTRIBUTE_RESPONSE.

Regards,

Mario

0 Kudos