Loading image on JN5169 dongle

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Loading image on JN5169 dongle

1,058 Views
edwarddow
Contributor I

Environment:

Win 7

Beyond Studio for NXP v1308

JN-AN-1189-ZigBee-HA-Demo v1470

Production Flash Programmer v1295

JN5169 dongles

TCP light bulbs with JN5168A chip

What I am trying to do is reprogram/flash the TCP light bulb with new firmware.

I'm stuck trying to put DimmableLight_JN5168_DR1175_LED_EXP_MONO_OTA_v2.ota  on the JN5169 dongle in external flash.

When I use the flash programmer with this  command it gives me the following error:

JN51xxProgrammer.exe -sCOM9 -S external -f DimmableLight_JN5169_DR1175_LED_EXP_MONO_OTA_v2.ota

"The loaded file does not appear to be a valid image"

I thought it might have to do with the fact that the dongle has a JN5169 chip but I need to load new OTA firmware on a JN5168 chip. So I tried to use DimmableLight_JN5169_DR1175_LED_EXP_MONO_OTA_v2.ota, but I got the same result.

Thoughts or ideas?

0 Kudos
2 Replies

653 Views
edwarddow
Contributor I

Found the manufacturers code by issuing a "Node Req" from the ZigBee Gateway User Interface.  This is a Node Descriptor Request send by the server to a node.

This reported the manufactures code so I grabbed it and plugged it into the above code/macro.  Still not sure what the ZigBee Configuration Diagram is or where it's located?  

I found some other references in other .h files to the manufacturers code so I changed them as well.  

It still did not do an upgrade.

Ideas?

0 Kudos

653 Views
edwarddow
Contributor I

Alright, so I've made some progress just not as much as I've hoped for.

Found the ZigBee Gateway User Interface after digging around.  Doc is JN-AN-1223

Loaded the ZigbeeNodeControlBridge onto the dongle with the flash programmer.

Ex: JN51xxProgrammer.exe -s com9 -f ZigbeeNodeControlBridge_JN5169.bin

This allows me to pair a bulb and it says do an OTA update.

I can load the image I made through the GUI.  Not sure if it's writing it to external flash on the dongle or what?  But it does read some information from it.

It never appears to make it to the bulb. 

I am suspicious that it has something to do with the "manufacture code" that is set in the manu_config.mk file.

# The manufacturer code is allocated by the ZigBee Alliance and is reported
# by a device when responding to a Node Descriptor Request. In addition to
# changing the macro below the manufacturer code in the Node Descriptor
# contained within the ZigBee Configuration diagram must also be changed to
# the same value.
MANUFACTURER_CODE             ?= 0x1037

The comments in the above code seem to indicate that you change it here and the ZigBee Configuration Diagram? 

What is the ZigBee Configuration Diagram? And where do I find it?

I also don't know what the manufacture code is for these TCP bulbs. Any ideas?

0 Kudos