KW36 unable to connect with devices

cancel
Showing results for 
Search instead for 
Did you mean: 

KW36 unable to connect with devices

321 Views
nsuresh2
Contributor III

If Advertising with Random public address with privacy enabled with Mode 1 level 3/level4, some devices (Samsung S9, Android Version: 9.0) doesn't get connect

Regards,

Naven Suresh

Tags (3)
0 Kudos
2 Replies

165 Views
mario_castaneda
NXP TechSupport
NXP TechSupport

Hi Naven,

I ran some test by my side, I used Android 9 and Samsung S9, the HID device example. I enabled the Privacy, as you did.

/* SMP Data */
gapPairingParameters_t gPairingParameters = {
    .withBonding = gAppUseBonding_d,
    .securityModeAndLevel = gSecurityMode_1_Level_3_c, 
    .maxEncryptionKeySize = mcEncryptionKeySize_c,
    .localIoCapabilities = gIoDisplayOnly_c,
    .oobAvailable = FALSE,
    .centralKeys = (gapSmpKeyFlags_t) (gLtk_c | gIrk_c),
    .peripheralKeys = (gapSmpKeyFlags_t) (gLtk_c | gIrk_c),
    .leSecureConnectionSupported = TRUE,
    .useKeypressNotifications = FALSE,
};

/*! Enable/disable use of bonding capability */
#define gAppUseBonding_d   1

/*! Enable/disable use of pairing procedure */
#define gAppUsePairing_d   1

/*! Enable/disable use of privacy */
#define gAppUsePrivacy_d   1

What is the example that you are working on?

Regards,

Mario

0 Kudos

165 Views
zhi_wang
Contributor III

hi Mario,

i  have a problem about Pairing and bonding, please check

 https://community.nxp.com/message/1195965?commentID=1195965#comment-1195965  

while the pairing and bonding and encryption are working fine, but cannot access to the encryption  required Characteristic value and description.

Regards,

Ziv

0 Kudos