KW36 required: RSA 1024 algorithm library support

cancel
Showing results for 
Search instead for 
Did you mean: 

KW36 required: RSA 1024 algorithm library support

110 Views
Contributor IV

Hi,

The current nxp sdk of kw36 does not support RSA 1024 encryption/decryption algorithm.

Will nxp be able to add RSA-1024 code in our framework in the nxp sdk we have? 

Regards

Sai Kalyana Raman

Labels (3)
0 Kudos
1 Reply

14 Views
NXP TechSupport
NXP TechSupport

Hello Sai Kalyana,

As you mention de current stack doesn't support the RSA encryption so I will suggest to use the mbedLTS library for this.

In the SDK from the FRDM-KW41 this library is already integrated so could check the example frdmkw41z_demo_apps_mbedtls_mbedtls_benchmark, copy the folder mbedtls and update the paths of your project.

pastedImage_1.pngpastedImage_2.png

I hope this helps you.

Best Regards,

Alexis Andalon

0 Kudos