How to change the baudrate of ZigbeeNodeControlBridge for JN5169?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to change the baudrate of ZigbeeNodeControlBridge for JN5169?

Jump to solution
381 Views
YeelongWong
Contributor III

Hi,there

I am developing based on JN-AN-1223-ZigBee-IoT-Gateway-Control-Bridge-v1014, and I want to connect this ZigBee JN5169 to another MCU, but I want to change the baudrate to 115200, and failed:(

I saw the default value is 1000000 in the Mafefile, why it can not work after I update it to 115200?

Can anybody help answer this question?

Tks sooooo much!!!

0 Kudos
1 Solution
311 Views
YeelongWong
Contributor III

Hi, all

In the end, I gave up the idea to change the baudrate, because the project code can not support this feature very well.

I update the baudrate of the other node to 1000000 bps to make them two nodes communicate.

Tks!

View solution in original post

0 Kudos
3 Replies
312 Views
YeelongWong
Contributor III

Hi, all

In the end, I gave up the idea to change the baudrate, because the project code can not support this feature very well.

I update the baudrate of the other node to 1000000 bps to make them two nodes communicate.

Tks!

View solution in original post

0 Kudos
373 Views
mario_castaneda
NXP TechSupport
NXP TechSupport

Hi @YeelongWong,

I hope you are doing great.

You could change the UART baud rate in the makefile. BAUD ?= 1000000

Also, the debug UART baud rate is different, so you have to change this as well.

    /* Send debug output to DBG_UART */
    DBG_vUartInit(DEBUG_UART, DBG_E_UART_BAUD_RATE_115200);

 

Regards,

Mario

0 Kudos
352 Views
YeelongWong
Contributor III

Hi, Mario,

The project ZigbeeNodeControlBridge has two uart channels.

UART0 is for control channel, which is used to transport the cmd and response, the default baudrate is 1000000.

1makefile.png2 uart.png

UART1 is the debug port, which is used to output the log, whose default baudrate is 115200, but also disabled as default.

 

Now, I was planning to change the UART0 baudrate to 115200 from 1000000.I think I should update the BAUD ?= 1000000 and it should be ok. Because this number will defined to CFLAGS += -DUART_BAUD_RATE=$(BAUD) and the source code will use 

 

/* Set the clock divisor register to give required buad, this has to be done
directly as the normal routines (in ROM) do not support all baud rates */
UART_vSetBaudRate(UART_BAUD_RATE);

 

As you mentioned, the debug port baudrate is already 115200, if this port is desired to be used, just enable this line:

DEBUG_PORT ?= UART1 is ok.

 

The problem is: change the UART0 baudrate to 115200 from 1000000, the system is down:(

 

B.R.

Yeelong

0 Kudos