How to bind Output ON/OFF cluster to JN5189 coordinator (IoT control bridge).

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to bind Output ON/OFF cluster to JN5189 coordinator (IoT control bridge).

1,243 Views
kollepara_b
Contributor II

I am working with #jn5189 as ZigBee coordinatore. I am trying to bind a LUMI mini switch ON/OFF cluster (Output cluster) with the coordinator. I am using IoT-control-bridge workspace, I am sending "BIND REQUEST" to the switch and getting a bind response as success, but when I tried to trigger an event from the switch, I am not receiving any data in the ZGUI tool, but If I see the sniffer logs I am able to see that the switch is sending on/off command to the coordinator. 

The same "BIND REQUEST" is working for device having ON/OFF cluster as a input cluster. Can anyone explain what can be done?

Labels (1)
4 Replies

1,106 Views
mario_castaneda
NXP TechSupport
NXP TechSupport

Hi Bharadwaj,

Finding and Binding’ is the process in which ‘controller’ type devices (e.g. switches) are bound to ‘controlled’ type devices (e.g. lights). So, I recommend to use the JN-AN-1244 Light Bulbs, You can bound the control bridge with the light bulb or the switch controller with the light bulb.

Please look at the 5.2.3 Finding and Binding JN-AN-1244 Documentation folder.

Regards,

Mario

0 Kudos

1,106 Views
kollepara_b
Contributor II

Hi Mario,

Actually when I send "BIND REQUEST" to a bulb or  with Mesg type = 0x0030 for ON/OFF cluster (which is in INPUT CLUSTER), from the co-coordinator (IoT Control Bridge) it works fine. But when I tried the same with LUMI mini switch (ZigBee device ID = ON_OFF_Light_switch) it is not working, the only difference is that the ON/OFF cluster is in OUTPUT CLUSTERS.

Whenever I send "BIND REQUEST" for ON/OFF cluster in Lumi mini switch, I am getting Bind response as successful and if I see the sniffer logs, the switch is sending the ON/OFF events to the coordinator (IoT control Bridge), but I am not receiving any data on the ZGUI tool. 

In my testing and development, I think that the Bind request only works for INPUT clusters, but in my case the ON/OFF cluster is part of OUTPUT clusters. 

0 Kudos

1,106 Views
mario_castaneda
NXP TechSupport
NXP TechSupport

Hi Bharadwaj,

Is it possible that you could provide your sniffer log and the terminal log?

Regards,

Mario

0 Kudos

1,106 Views
kollepara_b
Contributor II

Thank you Mario,

Turns out the problem is, I did not enable client side of the on/off cluster in the coordinator side.