Eclipse update site with plug-ins for ZigBee PRO is not availabe

cancel
Showing results for 
Search instead for 
Did you mean: 

Eclipse update site with plug-ins for ZigBee PRO is not availabe

564 Views
Contributor I

I'm a JN5148 user, and recently I was facing re-install the "JN5148 Software Developer’s Kit" by following the instruction from "JN-UG-3064-JN5148-SDK-2v0.pdf", everything went right except when I was trying to "Installing the Configuration Editors (ZigBee PRO)" (on page33), the update site you provide (http://eclipse.jennic.com/update-site) is no longer available. I can't do any further work associated with ZigBee PRO until this problem is fixed. Anybody know any solution for this? I really appreciate that!

Labels (2)
0 Kudos
2 Replies

2 Views
Contributor I

I'm also interrested by the new link to have access to the site http://eclipse.jennic.com/update-site. I would like to change my ZigBee configuration. Without this link I can't modify my zpscfg file with this Eclipse plugin.

Thanks.

0 Kudos

2 Views
Contributor I

I did it !

This instructions work for me:

  1. Install JN-SW-4141     BeyondStudio for NXP
  2. Install JN-SW-4170     JN516x ZigBee 3.0 SDK
  3. Try to launch Beyond Studio (if Beyon Studio don't want to open, reinstall JN-SW-4141) (I have this trouble on my computer)
  4. Follow the instructions in the document JN-UG-3098.pdf, chapter 1.2.3Installing the ZigBee Plug-ins (the plug-ins are available on your hard drive since the JN-SW-4170 integrate the source files of this plug-ins.)

/***/

To install tools for build project into BeyondStudio for JN5148, you should have an old installer. In the c:\Jennic (installation directory default of the old sdk), copy the folder Chip, cygwin, Components, Platform, into the install directory C:\NXP\bstudio_nxp ; Modify the file Jennic_Cygwin.bat located into the cygwin folder (C:\NXP\bstudio_nxp\cygwin).

Import an old project into Beyond Studio, right clic on the project->properties. In C/C++ Build->  environment, set the CYGWIN_HOME with C:\NXP\bstudio_nxp\cygwin

Remove all the file in the build folders EXEPT the makefile.

Left clic on the hammer to build your project and you will see some mistake. You have to copy into the C:\NXP\bstudio_nxp\Tools some old tools located in c:\Jennic\Tools. To know which one, you have to look at the compilation errors in the console windows. For my project, I have to copy OVLYUtils, OSconfig, ba-elf-ba2, PDUMConfig, ZPSCONFIG

0 Kudos