Can't connect device with BeeKit 3.0.2 to old network

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't connect device with BeeKit 3.0.2 to old network

234 Views
etiennebechara
Contributor I

Greetings,

I have a customer going through the following problem, and we are not being able to reach a conclusion:

He has a ZigBee network using various MC13226 compiled with BeeKit 3.0.1. Currently, this network can't be changed.

When he tries to insert a new device (the same one with MC13226), but this time compiled with BeeKit 3.0.2, the new device imemdiately disconnects from the network during the key exchange.

Is anybody familiar with a similar situation and can helus on what should we do to solve it?

Thanks in advance.

Labels (1)
Tags (2)
0 Kudos
1 Reply

103 Views
AngelC
Senior Contributor I

Dear Etienne,

Could you please specify the ZigBee profile and application templates you are using (i.e. ZHA OnOffLight, ZSE MeteringDevice, etc.)? I guess you are referring to codebase 3.0.11 and 3.0.12, or 3.0.12 and 3.1.1?

Also are you using the same security information as old network? Please share the configuration details regarding security in both devices (old and new codebase). If possible, please send a sniffer log to check the over-the-air messages. That will help to have a better context of the problem. Please also send the BeeStackConfiguration.h files of both projects whenever possible.

Regards,

AngelC

0 Kudos