OpenVG MQX Vybrid - error when calling eglCreateWindowSurface

cancel
Showing results for 
Search instead for 
Did you mean: 

OpenVG MQX Vybrid - error when calling eglCreateWindowSurface

Jump to solution
383 Views
Contributor III

Hi,

My system includes the following components:

- Freescale MQX4.1

- Freescale Vybrid VF522

- OpenVG 0.7.0

When I want to use another colorformat than ARGB8888, I get the error EGL_NO_SURFACE, when calling eglCreateWindowSurface.

I get the error when using RGB888 or RGB565.

I don't have the OpenVG sources, so I don't know what's going wrong inside this function.

Any hints ?

Regards

Sebastian

Labels (2)
0 Kudos
1 Solution
14 Views
Contributor III

Hi,

I have found a solution.

I first have to set the same color-format in the buffer-info of the fbdev-driver, cause they have to match and openvg-lib does not set itself this information.

fb = fopen("fbdev:0", NULL);

buf_info.FORMAT = FBDEV_COLOR_RGB888;

...

ioctl(fb, IO_IOCTL_FBDEV_SET_BUFFER_INFO, &buf_info);

...

//search for matching egl-config

...

eglCreateContext( ......);

Regards

Sebastian

View solution in original post

0 Kudos
3 Replies
14 Views
Senior Contributor II

ioseph_martinez could you assist with this question?

Thanks,

Jozef

0 Kudos
14 Views
NXP Apps Support
NXP Apps Support

timesyssupport can you  help with this case?

0 Kudos
15 Views
Contributor III

Hi,

I have found a solution.

I first have to set the same color-format in the buffer-info of the fbdev-driver, cause they have to match and openvg-lib does not set itself this information.

fb = fopen("fbdev:0", NULL);

buf_info.FORMAT = FBDEV_COLOR_RGB888;

...

ioctl(fb, IO_IOCTL_FBDEV_SET_BUFFER_INFO, &buf_info);

...

//search for matching egl-config

...

eglCreateContext( ......);

Regards

Sebastian

View solution in original post

0 Kudos