Memory POST test in T4240 SPL

cancel
Showing results for 
Search instead for 
Did you mean: 

Memory POST test in T4240 SPL

898 Views
michaelborgelt
Contributor II

I want to execute the Memory POST test (CONFIG_SYS_POST_MEMORY) in T4240 U-Boot. The board boots from SPI-Flash. Since the "normal" U-Boot runs already in DDR, the test should be started in the SPL-loader. Has anybody ever run this test in SPL-loader?

Labels (1)
4 Replies

327 Views
Pavel
NXP TechSupport
NXP TechSupport

Look at the following page from Community about 2GByte RAM under u-boot:

https://community.nxp.com/thread/372327


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

327 Views
Pavel
NXP TechSupport
NXP TechSupport

It looks like that The T4240 e6500 L3 cache can be used as SRAM for your memory test code.

The u-boot binary image is 768KBytes. The T4240 e6500 L2 SRAM bank size is 512KBytes. Therefore the T2080 e6500 L2 SRAM cannot be used for u-boot.

It looks like that your memory test code can be loaded to L2 SRAM. Board can be restarted after memory test for u-boot loading.


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

327 Views
michaelborgelt
Contributor II

Hi Pavel,

thanks for your answer. So far I have the Memory tests are running in SPL. But only for the first 2 GByte of RAM. Do you know how to address the whole RAM?

SPL maps only the first 2 GByte of RAM, I have configurations with 6 and 12 GByte.

U-Boot Output:

Initializing....using SPD
4 GiB left unmapped
    DDR:

0 Kudos

327 Views
gottfriedwutzl
Contributor II

Dear Michael,

which memory test is it? How can the memory test be added to the SPL?

I only need a factory test to check if all address and data lines soldered (short circuit, open lines)?

regards,

Gottfried

0 Kudos