How to update Glibc version in yocto sdk v2.0

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to update Glibc version in yocto sdk v2.0

7,044 Views
Suraj_Prakash
Contributor II

Hi,

  Currently the sdk which we are using has the glibc 2.22 .Can anyone please suggest how can we get the glibc 2.28 in the yocto sdk V2.0 ??

0 Kudos
15 Replies

7,036 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please backup sources/meta-freescale/recipes-core/glibc/ to other place, please extract the attached file in folder sources/meta-freescale/recipes-core/.

Please modify GLIBCVERSION_qoriq-ppc to 2.28 in sources/meta-freescale/conf/distro/fsl-qoriq.conf.

GLIBCVERSION_qoriq-ppc = "2.28"

Then rebuild glibc and rootfs filesystem.

$ bitbake glibc

$ bitbake fsl-image-core

7,033 Views
Suraj_Prakash
Contributor II

I have got the following errors

$ bitbake glibc

WARNING: Host distribution "Ubuntu-16.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.
ERROR: ParseError at /home/suchita/GCR/v2/QorIQ-SDK-V2.0-20160527-yocto/sources/meta-freescale/recipes-core/glibc/glibc-ld.inc:1: Could not inherit file classes/linuxloader.bbclass

 

0 Kudos

7,019 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please put the attached linuxloader.bbclass and nopackages.bbclass in folder sources/poky/meta/classes/.

0 Kudos

7,006 Views
Suraj_Prakash
Contributor II

Hi,

     I am getting the following error while  doing bitbake.Please suggest a solution

 

$bitbake glibc


WARNING: Host distribution "Ubuntu-16.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.
Loading cache: 100% |####################################################################################################################################| ETA: 00:00:00
Loaded 3824 entries from dependency cache.
WARNING: Unable to get checksum for lib32-openssh SRC_URI entry fix-potential-signed-overflow-in-pointer-arithmatic.patch: file could not be found | ETA: --:--:--
WARNING: Unable to get checksum for lib32-openssh SRC_URI entry sshd_check_keys: file could not be found
WARNING: Unable to get checksum for lib32-openssh SRC_URI entry disable-ciphers-not-supported-by-OpenSSL-DES.patch: file could not be found
WARNING: Unable to get checksum for openssh SRC_URI entry fix-potential-signed-overflow-in-pointer-arithmatic.patch: file could not be found
WARNING: Unable to get checksum for openssh SRC_URI entry sshd_check_keys: file could not be found
WARNING: Unable to get checksum for openssh SRC_URI entry disable-ciphers-not-supported-by-OpenSSL-DES.patch: file could not be found
Parsing recipes: 100% |##################################################################################################################################| Time: 00:00:23
Parsing of 2696 .bb files complete (1781 cached, 915 parsed). 6082 targets, 702 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
NOTE: multiple providers are available for make-native (make-native, remake-native)
NOTE: consider defining a PREFERRED_PROVIDER entry to match make-native

Build Configuration:
BB_VERSION = "1.28.0"
BUILD_SYS = "x86_64-linux"
NATIVELSBSTRING = "Ubuntu-16.04"
TARGET_SYS = "powerpc64-fsl-linux"
MACHINE = "t1040d4rdb-64b"
DISTRO = "fsl-qoriq"
DISTRO_VERSION = "2.0"
TUNE_FEATURES = "m64 fpu-hard e5500"
TARGET_FPU = "hard"
meta
meta-yocto
meta-yocto-bsp = "HEAD:9a211a4a2c1bfcb292dc97d8dcac149bca9e3f1b"
meta-oe
meta-multimedia
meta-gnome
meta-networking
meta-perl
meta-python
meta-ruby
meta-filesystems
meta-webserver
meta-xfce = "HEAD:dc5634968b270dde250690609f0015f881db81f2"
meta-freescale = "HEAD:7facbdb726e2dda0515e084c2066a4b8dd99c6d2"
meta-freescale-internal = "HEAD:4829293f807e35a1111e79763294fc8b98b97810"
meta-freescale-extra = "HEAD:bee911b027e0480b034674d0ddee3fcb06d2e985"
meta-virtualization = "HEAD:042425c1d98bdd7e44a62789bd03b375045266f5"
meta-java = "HEAD:8b776ac68f9af4596be3824152bcf0bc6b67fa1d"
meta-openstack
meta-openstack-aio-deploy
meta-openstack-compute-deploy
meta-openstack-compute-test-config
meta-openstack-controller-deploy
meta-openstack-controller-test-config
meta-openstack-qemu
meta-openstack-swift-deploy
meta-cloud-services = "HEAD:d8bc0d92d0f741e2ea1e6d3d9bc6b7a091d03cfb"
meta-security = "HEAD:f9367e71f923fc7d2fb600208e2b97535ea41777"
meta-nxp-npi-1701 = "jethro-sdk-v2.0-ga-1701:11975eebce9096a3567d00ba2067a2dbd2ed4d5c"

NOTE: Preparing RunQueue
ERROR: An uncaught exception occured in runqueue, please see the failure below:
ERROR: Running idle function
Traceback (most recent call last):
File "/home/suchita/GCR/v2/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/cooker.py", line 1387, in buildTargetsIdle(server=<ProcessServer(ProcessServer-1, started)>, rq=<bb.runqueue.RunQueue instance at 0x7f4e230de998>, abort=False):
try:
> retval = rq.execute_runqueue()
except runqueue.TaskFailure as exc:
File "/home/suchita/GCR/v2/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/runqueue.py", line 1105, in RunQueue.execute_runqueue():
try:
> return self._execute_runqueue()
except bb.runqueue.TaskFailure:
File "/home/suchita/GCR/v2/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/runqueue.py", line 1040, in RunQueue._execute_runqueue():
self.rqexe = RunQueueExecuteDummy(self)
> if self.rqdata.prepare() == 0:
self.state = runQueueComplete
File "/home/suchita/GCR/v2/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/runqueue.py", line 587, in RunQueueData.prepare():
for dep in recursiveitasks[task]:
> generate_recdeps(dep)

File "/home/suchita/GCR/v2/QorIQ-SDK-V2.0-20160527-yocto/sources/poky/bitbake/lib/bb/runqueue.py", line 575, in generate_recdeps(t=None):
newdeps = set()
> add_resolved_dependencies([taskData.tasks_fnid[t]], tasknames, newdeps)
extradeps[task].update(newdeps)
TypeError: list indices must be integers, not NoneType

0 Kudos

6,997 Views
yipingwang
NXP TechSupport
NXP TechSupport

GLIBC 2.28 recipes from Openembedded are not compatible with Linux SDK 2.0 build environment. It's difficult to port Glibc 2.28 in Linux SDK 2.0, please consider still using Glibc 2.22 or 2.20.

0 Kudos

6,977 Views
Suraj_Prakash
Contributor II

Hi,

      Since like you said it is difficult to use Glibc 2.28 with Linux SDK 2.0 build environment,is there any way to update my existing Linux SDK 2.0 to higher version and then use Glibc 2.28?

Please help me fix the issue.Thanks in advance.

0 Kudos

6,971 Views
yipingwang
NXP TechSupport
NXP TechSupport

You could consider to use the latest Yocto 3.1 release from NXP.

https://source.codeaurora.org/external/qoriq/qoriq-components/yocto-sdk/tree/readme?h=dunfell

It integrates glibc 2.31.

0 Kudos

6,889 Views
Suraj_Prakash
Contributor II

Hi,

       

please suggest how to download yocto 3.1

 

 

Thanks

suraj

0 Kudos

6,883 Views
yipingwang
NXP TechSupport
NXP TechSupport
Install 'repo' tool
===================
To use this manifest repo, the 'repo' tool must be installed first
```
$: mkdir ~/bin
$: curl http://commondatastorage.googleapis.com/git-repo-downloads/repo  > ~/bin/repo
$: chmod a+x ~/bin/repo
$: PATH=${PATH}:~/bin
```

Download Yocto Layers
=====================
The following is the step of how to use repo utility to download all Yocto layers according to the repo manifest. Replace <branch> with the real name (see Yocto branch and version below).

```
$: mkdir yocto-sdk
$: cd yocto-sdk
$: repo init -u https://source.codeaurora.org/external/qoriq/qoriq-components/yocto-sdk -b dunfell
$: repo sync -- force-sync 

 Please refer to https://source.codeaurora.org/external/qoriq/qoriq-components/yocto-sdk/tree/readme?h=dunfell for details.

0 Kudos

6,959 Views
Suraj_Prakash
Contributor II

Hi,

        Is there any solution apart from shifting to Sdk 3.1. Can i cross compile glibc separetly and use it on the board.If yes please suggest a solution.

Thanks in advance.

0 Kudos

6,939 Views
yipingwang
NXP TechSupport
NXP TechSupport

It is impossible to cross compile glibc separately. All rootfs packages depend on glibc, if you upgrade glibc to higher version, all packages in rootfs should be rebuilt.

0 Kudos

6,966 Views
Suraj_Prakash
Contributor II

Hi,

      I am using t1040 reference board and does sdk 3.1 support the same

0 Kudos

6,960 Views
yipingwang
NXP TechSupport
NXP TechSupport

Yocto 3.1 doesn't provide support for T1040 directly, you could refer to T1042D4RDB or T1024RDB to create yocto configuration recipe for T1040D4RDB.

 

0 Kudos

6,283 Views
Suraj_Prakash
Contributor II

How to create a receipe for T1040 in SDK 3.1?

0 Kudos

6,920 Views
Suraj_Prakash
Contributor II

Hi,

     Do you have any procedure to do the configuration for T1040 in sdk 3.1?

0 Kudos