Upgrading CW from 10.6.4 to 11.x

cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading CW from 10.6.4 to 11.x

Jump to solution
112 Views
Maciek
Contributor V

Hi,

we use currently CW for MCU v10.6.4 (with license generated for 10.5) - it's Professional perpetual license.

Can we download and use current CW for MCU 11.1  with this same license file ?

If not - how to get/generate license file ?

Regards

Maciek 

0 Kudos
1 Solution
96 Views
lisettelozano
NXP Employee
NXP Employee

Hi Maciek, 

Our licenses can be backward compatible but not forward compatible. For example, you can use the license for v11.1 with the installer of v10.6 but you can't use the license of v10.6 with the installer of v11.1. 

In this case, for you to have access to the v11.1, you will need to renew your technical support maintenance contract. Remember that our perpetual products are permanent but it comes with the first year of the tech support contract. After that first year, you will only have access to the versions released until that date permanently. With this being said, your product tech support contract expired back in 2014, so this is why the v11.1 is not offered until its renewed. 

For more details about this and how to renew, please check or Licensing and Registration FAQ here https://www.nxp.com/design/software/development-software/codewarrior-development-tools/licensing-and...

Best Regards, 

Paulina

View solution in original post

0 Kudos
1 Reply
97 Views
lisettelozano
NXP Employee
NXP Employee

Hi Maciek, 

Our licenses can be backward compatible but not forward compatible. For example, you can use the license for v11.1 with the installer of v10.6 but you can't use the license of v10.6 with the installer of v11.1. 

In this case, for you to have access to the v11.1, you will need to renew your technical support maintenance contract. Remember that our perpetual products are permanent but it comes with the first year of the tech support contract. After that first year, you will only have access to the versions released until that date permanently. With this being said, your product tech support contract expired back in 2014, so this is why the v11.1 is not offered until its renewed. 

For more details about this and how to renew, please check or Licensing and Registration FAQ here https://www.nxp.com/design/software/development-software/codewarrior-development-tools/licensing-and...

Best Regards, 

Paulina

View solution in original post

0 Kudos