LF signal reception on NTM88 TPMS

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

LF signal reception on NTM88 TPMS

578 Views
nikita_kanade
Contributor I

Hello,

I am trying to receive the data on LF module in NTM88 TPMS.

Configured the LF module in Data reception mode

device wakeup Due to LF carrier and error flag is set

so unable to debug where is problem like in Premble or sync byte or in wakeup id or in data

Is any way to check received data on LF module like connecting any pin to DSO.

I used X-TPMS88EH11S434 board as LF receiver

and LF transmitter which send 2 ms preamble , 9 T pattern of sync pattern, 2 byte of wakeup id

Following are my LF module setting:

LFCTL1_LFEN = 0;

/* Wait 3ms before writing in the registers */
Delay_TPM_ms(3);

/* Low consumption during sniff mode + LF Ack */
LFS = (LFS_LPSM_MASK | LFS_LFIAK_MASK);

/* LFCTRLE to LFCTRLB are taken care of by vnfLFRConfigFactoryRegs called in TPMS_LF_ENABLE() */

LFCTRLA = 0;
LFCTRLB_LFPOL = 1;
LFCTL2 = 0;
LFCTL3 = (LFCTL3_T9_PATTERN | LFCTL3_DATA_1024_USEC_CARRIER_1024_USEC);

/* Enable Data Mode interrupts, enable the digital decoder and carrier */
/* validation, and set sync time-out */
LFCTL4 = (LFCTL4_LFDRIE_MASK | LFCTL4_DCEN_MASK | LFCTL4_VALEN_MASK
| LFCTL4_SYNC_SET_TO_24_MSEC | LFCTL4_LFCDIE_MASK | LFCTL4_LFIDIE_MASK);//|LFCTL4_LFERIE_MASK);

/* Set ID values */
LFIDH = ((UINT8) 0x12u);
LFIDL = ((UINT8)0x34u);

/* Disable carrier mode */
LFCTL1_CARMOD = 0;

/* Set ID type to 16-bit type */
LFCTL1_IDSEL = IDSEL_TYPE_16_BIT;

/* Set sensitivity */
LFCTL1_SENS = 2; // High sensitivity

 

0 Kudos
Reply
1 Reply

569 Views
JozefKozon
NXP TechSupport
NXP TechSupport

Hello Nikita,

the reason could be input saturation. Please refer to section  in AN4391. There is description of the fault and in section 4.2 is NXP recommendations how to solve it. The AN4391 can be downloaded from the NTM88 product page. There is lot of other documents to the NTM88 TPMS, which might interest you.

JozefKozon_0-1666257290413.png

With Best Regards,

Jozef

0 Kudos
Reply