KL17 Sensor fusion V7.0 Magnetic calibration

cancel
Showing results for 
Search instead for 
Did you mean: 

KL17 Sensor fusion V7.0 Magnetic calibration

721 Views
Contributor I

Dear All,

 

We have designed a new board with KL17 & Compass FXOS8700CQ and gyroscope FXAS21002 sensors.

 

We try to calibrate the sensors using toolbox. In magnetic calibration, fit error is not reducing below 13%.

 

We have followed all the recommended PCB guidelines.

 

Herewith I have attached the video capture file for reference. 

 

It will be of great help if anyone can help us to solve the issue

 

Regards,

Kayathri

Original Attachment has been moved to: magnetics.txt.zip

Labels (1)
0 Kudos
9 Replies

47 Views
NXP Employee
NXP Employee

I'm pretty sure you've come up against a known error in the V7.xx code that was described in https://community.nxp.com/ideas/1675" modifiedtitle="true" title="If you are having MagCal issues... That error limits you to a hard iron calibration only, which is what I see in your video. It's a really simple change.  Please give it a try and let me know if that resolves the problem.

Regards,

Mike

0 Kudos

47 Views
Contributor I

Hi Mike,

After the above change, measurements is roll between 0 to 360, but magnetometer is not calibrated. Once it happened with fit error 9%.

Regards,

Kayathri

0 Kudos

47 Views
Contributor I

Hi Mike,

And one more problem application is taking 50ms to complete the task whereas KL46 is taking nearly less than 40ms.

if (true == pitIsrFlag) { // Check whether occur interrupt and toggle LED
...
pitIsrFlag = false; // Reset the flag for the next cycle
}

Output data rate is not 40ms. It is 80ms.

I have attached waveform of timing for reference.

Both KL46 & KL17 runs at 48MHZ.   

Regards,

Kayathri

0 Kudos

47 Views
NXP Employee
NXP Employee

Kayathri,

I need more precision in your comments.  You mention KL17Z and KL46Z.  Is the KL17 on your board and the the KL46Z on a standard NXP board?  Did you port the V7.xx code to both?  Do both have all the same sensor orientations?  Are both having MagCal problems, or just the KL17?  Which Frame of Reference are you using?  Have you reviewed Table 6 in the data sheet, which reviews gimbal lock issues for the 3 different variations.  The maximum roll range for any of those is +/- 180.  Are you sure you are not looking at compass heading, which is derived from yaw?  For output data rate, are you referring to the fusion output data rate, or sensor rate?  That is almost certainly related to your MCU/peripheral clock configuration.   Can you take another video showing the modified code operation on the magnetics screen?

Thanks,

Mike

0 Kudos

47 Views
Contributor I

MIke,

We have Custom board with KL17, KL46 +sensor board & Standard NXP board.

I have ported V7.0 on both custom board.  

KL17 has magnetic calibration problem whereas KL46 does not have this problem.

KL46 has yaw drift & We have not followed design guidelines. So, we have designed new board with KL17 & followed design guidelines

All sensor axes are aligned in custom board

We are using NED coordinate system. 

I was referring sensor fusion data rate and i was taking about magnetic measurements value on magnetic tab (toolbox)  not ROLL value.

I have attached calibration video herewith. 

Regards,

Kayathri

0 Kudos

47 Views
Contributor I

Dear Mike,

The new boards were assembled with magnetometer with IC (bought very recently) marking

263

8700

ENA 

We have replaced KL17 board the compass IC FXOS8700CQR1 with marking 

263

8700

DOC

which is same as old custom KL46. 

The same KL17 board is able to do magnetic calibration with fit error 6%. 

I have attached video for reference.

Regards,
Kayathri

0 Kudos

47 Views
NXP Employee
NXP Employee

Kayathri,

The fit error is a bit high, but not unreasonable in your video.  It appears that you have a 7-element magnetic calibration (hard iron plus on-diagonal soft iron components).  So I'm not clear on what the current problem is.  We can set up a SKYPE session if you would like.  What time zone are you in?

Mike

0 Kudos

47 Views
Contributor I

Hi Mike,

Sure, I would like to have a skype call.

We are based on GMT+ 5.5 (IST).

Regards,

Kayathri

0 Kudos

47 Views
NXP Employee
NXP Employee

Great, Please email your contact information to Mike.Stanley@nxp.com, and I'll set something up.  Let me know if you have a preferred time.

0 Kudos