question about S32K3X4EVB OpenSDA debugger

cancel
Showing results for 
Search instead for 
Did you mean: 

question about S32K3X4EVB OpenSDA debugger

Jump to solution
422 Views
snaku_lee
Contributor III

Hi,

I have a S32K3X4EVB, and I try to download a example program by its OpenSDA, but the Windows on my laptop doesn't probe this device. When I plugin the micro-USB, the D15 LED (i.e. RST_OSDA) will blink, but there is no OpenSDA device present in my Windows device manager. Should I change any jumper for OpenSDA? the jumpers on the EVB are default setting.

And I tried to debug the S32K344 on the EVM with PE's CycloneFX, it works fine.

I also have a S32K144EVB board, the OpenSDA is work properly on my laptop.

My S32DS version is 3.4.3 with S32K3xx development package 1.0.0.

 

S32K3_OpenSDA_Blinking.PNG

Thank you,

Snaku

Tags (2)
0 Kudos
1 Solution
372 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

with respect of drivers on PC, be sure you have S32K3 development package installed

PetrS_0-1646225260839.png

 

PetrS_1-1646225320311.png

 

Regarding K26 FW reflashing; it will be better to ask Pemicro support directly for giving latest FW and guide; https://www.pemicro.com/support

BR, Petr 

View solution in original post

0 Kudos
4 Replies
404 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

default jumper setting is mentioned in board user manual https://www.nxp.com/webapp/Download?colCode=S32K3X4EVB-Q172_HW-UM. Also you can try to follow Getting started guide; https://www.nxp.com/document/guide/getting-started-with-the-s32k3x4evb-q172-evaluation-board:GS-S32K...

After USB cable is connected below should appear in PC device manager

PetrS_0-1646138170728.png

and this is then selected in debug configuration

PetrS_1-1646138221979.png

BR, Petr

 

 

 

0 Kudos
387 Views
snaku_lee
Contributor III

Hi Petr,

My Windows doesn't detect the 'Multilink' device when I connect a micro-USB cable, and I check the jumpers setting with the 'getting start' page, they are in default position. 

S32K3_Multilink_Missed.PNG

I think maybe the 'OpenSDA' firmware in the K26 MCU is gone, if it was true, how do i reflash the K26 firmware? could you provide the web page?

Thank you,

Snaku

0 Kudos
373 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

with respect of drivers on PC, be sure you have S32K3 development package installed

PetrS_0-1646225260839.png

 

PetrS_1-1646225320311.png

 

Regarding K26 FW reflashing; it will be better to ask Pemicro support directly for giving latest FW and guide; https://www.pemicro.com/support

BR, Petr 

0 Kudos
348 Views
snaku_lee
Contributor III

Hi PetrS,

The 'S32K3xx development package' is installed in my S32DS.

I will ask PE to support me, thanks for your information.

Snaku

0 Kudos