The GDB Server was not able to establish a connection to the target processor.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

The GDB Server was not able to establish a connection to the target processor.

Jump to solution
614 Views
RickYeh777
Contributor III

I got the same error message both on my own board and S32K118EVB-Q064 recently.
Could you please give me any suggestion?

RickYeh777_0-1695633007868.png

RickYeh777_0-1695629814301.png

My OS: Windows 10
IDE: S32 Design Studio for S32 Platform, Version: 3.4, Build id: 201217 (Update 3)
Chip: S32K118

RickYeh777_1-1695630019579.png

RickYeh777_1-1695633126851.png

 

Below are the screenshots of my own board example.

RickYeh777_2-1695630218490.png

RickYeh777_3-1695630295630.png

I checked the port B connection and waveforms.

RickYeh777_4-1695630582751.png

RickYeh777_5-1695630723491.png

RickYeh777_6-1695630760620.png

Blue is SWD_DIO, it's kept at 0V, except for the last moment.
Red is /RESET, and Green is SWD_CLK.

Let's zoom in the last moment in the next screenshot.

RickYeh777_7-1695630970133.png

The period of /RESET is 800us.

Any suggestion will be much appreciated.

 

0 Kudos
1 Solution
565 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi

If you can read Chinese, it is recommended to read:S32K1xx系列MCU应用指南之芯片锁死(lockup)复位原因分析与恢复方法详解

Please try to halt the MCU by using P&E Recovery Utility first, see: Can't use PEmicro debugger with S32K118EVB2-Q048After halt the MCU, you should be able to debug it.

Check that Multilink's firmware is up to date. Please try to install USB Multilink Resources InstallThen update it by click C:\PEMicro\Multilink_Resources\PEFirmwareConfig.exe


Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

 

View solution in original post

0 Kudos
2 Replies
513 Views
RickYeh777
Contributor III

connector pin definition misunderstanding, sorry, it's corrected.

Thanks for your help.

0 Kudos
566 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi

If you can read Chinese, it is recommended to read:S32K1xx系列MCU应用指南之芯片锁死(lockup)复位原因分析与恢复方法详解

Please try to halt the MCU by using P&E Recovery Utility first, see: Can't use PEmicro debugger with S32K118EVB2-Q048After halt the MCU, you should be able to debug it.

Check that Multilink's firmware is up to date. Please try to install USB Multilink Resources InstallThen update it by click C:\PEMicro\Multilink_Resources\PEFirmwareConfig.exe


Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

 

0 Kudos