Supporting SDK 4.0.3 in different Version of S32DS

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Supporting SDK 4.0.3 in different Version of S32DS

Jump to solution
359 Views
DenisT1980
Contributor III

Hi all!

My current project is working under S32DS 3.4 with SDK 4.0.3

And I have some question regarding S32DS 3.5

1. Is it correct that S32DS 3.5 will support only SDK 4.0.1 and will not support 4.0.2 and further versions?

2. Are there some technical issues behind this?

3. Under what circumstances it makes sense to upgrade from version 3.4 (but with SDK 4.0.3) to version 3.5? (with SDK 4.0.1)

4. Will be SDK 4.0.3 supported in futures Version of S32DS?

 

Thank you advance for answers!

Tags (2)
0 Kudos
1 Solution
340 Views
VaneB
NXP TechSupport
NXP TechSupport

Hi @DenisT1980 

At the moment there is not any plan to integrate S32SDK S32K1XX 4.0.3 into S32DS 3.5 or above version.

Some issues have been reported with S32K1 support in S32DS v3.5, at this moment we still recommend for the S32K1 family use the S32DS v3.4. Also, it has support for the latest version of SDK (4.0.3) and RTDs (1.0.1) available for the family.

Sorry for the inconvenience. 

View solution in original post

0 Kudos
2 Replies
341 Views
VaneB
NXP TechSupport
NXP TechSupport

Hi @DenisT1980 

At the moment there is not any plan to integrate S32SDK S32K1XX 4.0.3 into S32DS 3.5 or above version.

Some issues have been reported with S32K1 support in S32DS v3.5, at this moment we still recommend for the S32K1 family use the S32DS v3.4. Also, it has support for the latest version of SDK (4.0.3) and RTDs (1.0.1) available for the family.

Sorry for the inconvenience. 

0 Kudos
310 Views
DenisT1980
Contributor III
Thank you!
0 Kudos