S32K188 runs with debugger, but not witout

cancel
Showing results for 
Search instead for 
Did you mean: 

S32K188 runs with debugger, but not witout

Jump to solution
372 Views
albertgalofre
Contributor II

Hi there,

I have created a project with "S32DS Application project" button, over the S32k188 micro controller; it just a blinking led. Works fine debugging with the Mutilink Universal debugger; BUT I unplug this debugger and after a reset the led is fix to OFF. Seems that the microcontroller doesn't start to run. I have set the optimization to "None".

I have tried a "S32DS Project from example" button (hello_world_s32k118) and adding the blinking led code; and works fine with and without debugger!!!!!!

There is something different inside the project parameters, between the example and the application. I have compared them and matched some parameters, but with the same results.

IDE:   S32 Design Studio for ARM        Version: 2.2     Build id: 200116

 

Where I could be failing? 

 

thanks a lot

 

Tags (3)
0 Kudos
1 Solution
344 Views
albertgalofre
Contributor II

understood, done and running!!!!!

Bravo for you, and bravo for the NXPCommunity.

Thanks a lot

View solution in original post

0 Kudos
5 Replies
345 Views
albertgalofre
Contributor II

understood, done and running!!!!!

Bravo for you, and bravo for the NXPCommunity.

Thanks a lot

View solution in original post

0 Kudos
360 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi albertgalofre,

Please add "START_FROM_FLASH" Symbols in "Standard S32DS Assembler".

START_FROM_FLASH Standard S32DS Assembler Symbols.png

Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos
305 Views
종찬박
Contributor II

Hi Robin.

I'm trying to solve same problem. but I can't see the tap that you let me see.

I think that's because I have another version S32DS.

I have S32 Design Studio for S32 Platform
 - Version: 3.3
 - Build id: 200610

image.png

I want to execute S32K188 without debugger.

What can I do?

0 Kudos
301 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Yes. There is a little different between S32DS 2.2 and 3.3.
You can open Standard S32DS Assembler -> Preprocessor and then add START_FROM_FLASH

START_FROM_FLASH S32 Design Studio for S32 Platform 3.3.png

0 Kudos
291 Views
종찬박
Contributor II

I'm afraid that it doesn't work.

I did already what you said so, but my board doesn't work.

when I control my board with debugger, it works well.

but, After power reset, it doesn't work.

0 Kudos