Problems occurred when debugging the S32K344 using JLINK on the S32DS IDE

cancel
Showing results for 
Search instead for 
Did you mean: 

Problems occurred when debugging the S32K344 using JLINK on the S32DS IDE

Jump to solution
567 Views
BrainLoader
Contributor I

Hi everyone, I am currently learning the security startup of S32K344. Unfortunately, I did not find any relevant learning materials for my reference.So I decided to start with an project example,I found the project named Hse_Ip_AesEncAsynclrq_S32K344 in the routine and created it,but when I used the JLINK debugger to connect and DEBUG, Breakpoints are incorrectly located in the middle of the main program instead of at the beginning, and hardware interrupt errors occur irregularly during debugging.And there were also errors in the operation of the program.image.pngimage.png

0 Kudos
1 Solution
502 Views
danielmartynek
NXP TechSupport
NXP TechSupport

The HSE FW and its documentation is under an NDA.

You should not be able to get it from other sources.

Yes, the demo uses Lauterbach Trace32, but it can be loaded with other debuggers.

If you need some assistance, please create a ticket instead of using this public community, because again, this is under NDA.

 

Thank you,

BR, Daniel

View solution in original post

0 Kudos
5 Replies
546 Views
danielmartynek
NXP TechSupport
NXP TechSupport

Hi @BrainLoader,

Is the HSE_FW installed on the MCU?

Do you have access to the S32K3 Secure files:

https://www.nxp.com/products/processors-and-microcontrollers/s32-automotive-platform/s32k-auto-gener...

danielmartynek_0-1679306022552.png

There are HSE DEMO, HSE reference manual and trainings.

 

NXP SECURE ACCESS RIGHTS FIRST-TIME USER REGISTRATION GUIDE

https://www.nxp.com/docs/en/user-guide/nxp-secure-access-rights-registration.pdf

 

Regards,

Daniel

 

0 Kudos
519 Views
BrainLoader
Contributor I

Hi @danielmartynek ,

Thanks again for your time to reply me. I have another question.

When I used the JLink debugger of SEGGER to debug my program, normally the program would stop at the entrance of main function, but when it was actually running, the program unexpectedly stopped at the middle part of main function.

I would like to know how to set the debugging to return to normal working state

The breakpoint displayed in the Debug View is in the middle of the program, not at the beginning

BrainLoader_0-1679643448262.png

These are my debugger configurations

BrainLoader_1-1679643533229.png

BrainLoader_2-1679643552400.png

 

 

 

 

0 Kudos
503 Views
danielmartynek
NXP TechSupport
NXP TechSupport

Hi @BrainLoader,

Can you please create a new thread for this last question as it is not related to the original topic of this thread?

 

Thank you,

BR, Daniel

0 Kudos
527 Views
BrainLoader
Contributor I
Thanks for your reply,I did not have HSE firmware installed on my MCU,And I don't have NXP Sercure Access Right, but I found relevant content in other posts and downloaded the file, but I wonder if the guide in the file uses the Louderbach debugger and trace32, I wonder if these are necessary, is there any other solution? For example, can I program HSE firmware using the SEGGER debugger?
0 Kudos
503 Views
danielmartynek
NXP TechSupport
NXP TechSupport

The HSE FW and its documentation is under an NDA.

You should not be able to get it from other sources.

Yes, the demo uses Lauterbach Trace32, but it can be loaded with other debuggers.

If you need some assistance, please create a ticket instead of using this public community, because again, this is under NDA.

 

Thank you,

BR, Daniel

0 Kudos