No SDK for S32K1xx MCUs in S32 DS

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No SDK for S32K1xx MCUs in S32 DS

194 Views
erikvk
Contributor I

Hi,

I am using your IDE S32 DS (version 3.5.10) to get started with your some of you processors, S32K344 and S32K146. And I find you supplied examples useful. However when I try to generate an "empty" project and using the supplied examples i run in to issue for the S32K146 MCU. 

To generate a new project I select file->new->S32DS Application project. But when I try to add a SDK there is non to select. See picture

 

Screenshot from 2024-02-23 09-35-00.png

 I have installed the development package version 3.5.4:

Screenshot from 2024-02-23 09-35-56.png

 I do not have the same issue when starting a new project for the S32K344 MCU. There I can select the proper SDK. However I have tried to install you supplied examples to use FreeRTOS with S32K344 MCU but after the installation the examples are not available in select file->new->S32DS Project From example. Or in the "S32DS extensions and updates" window. Se picture for installed FreeRTOS packages

Screenshot from 2024-02-23 09-54-24.png

In short, there are two issues:

1. There is no SDK to select for the S32K146 package even though all packages to my knowledge are installed

2. Ths FreeRTOS examples for S32K344 cannot be installed to the design environment

How should I proceed to solve my issues

Br

Erik

 

0 Kudos
Reply
1 Reply

157 Views
Senlent
NXP TechSupport
NXP TechSupport

Hi@erikvk

1.From your description, I found that you did not install the S32K1 RTM driver package.

for example, below is what i have installed for S32K1

Senlent_0-1708914122756.png

2.The version of FreeRTOS must be consistent with the RTD version you are currently using.

0 Kudos
Reply