Internal error during Start GDB Semihosting Job on S32DS

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Internal error during Start GDB Semihosting Job on S32DS

3,047 Views
hoona75
Contributor I

Hello Nxp,

 

Our third-party have faced a problem as below snapshot. They are using the PEMicro multilink USB. 
We checked the S32DS configuration together. But, not found any mis-configuration. 
Could you help us solve this problem. We are welcome any suggestions.

hoona75_0-1695804235813.jpeg

Thank you.

0 Kudos
6 Replies

1,311 Views
CY9
Contributor I

After almost half year

The same issus still on 5.7.6.202312041432 com.pemicro.debug.gdbjtag.pne.feature.feature.group 

waste my time 

0 Kudos

3,014 Views
Daniel-Aguirre
NXP TechSupport
NXP TechSupport

Hi,

It seems that the following thread might be related to this request:

Unable to Debug project using PEMicro Debugger - NXP Community

Is this correct? If not, please let us know.

0 Kudos

2,987 Views
RickYeh777
Contributor III

I got the same problem and worked around.
Just uninstall the latest update of PEmicro as below.
RickYeh777_0-1696409453102.png

And reinstall the previous version of them.

RickYeh777_1-1696409780462.png

 

0 Kudos

2,952 Views
julienrochette
Contributor I

Hi, where can you find an old version of the plugin or how did you roll back? I can not debug anything since the update.

thank you

0 Kudos

2,928 Views
RickYeh777
Contributor III

Two places to uninstall.

1. Help->Installation Details

RickYeh777_0-1696552072257.png

2.Help->S32DS Extensions and Updates

RickYeh777_1-1696552154667.png

Help->Install New Software, to get the previous version, 5.2.0.20220321...

RickYeh777_2-1696552415020.png

But if "C:\NXP\S32DS.3.4\S32DS\tools\gdb-arm" is cleared, you maybe need to run the install program of S32DS again.

2,428 Views
ctunder77
Contributor I

Hello, 

   I have the error described in this thread and have tried to revert the components to the version in the thread but I only have access to a more recent subset of the components. Is there a way to get access to the "older" version that may work? I am not sure if I have another problem in my configuration so I have included what I have seen other threads mention.

Below are the versions of the debugging support and device expansion plugin I can access from the software installer.

ctunder77_1-1700019526452.png

This is my version of S32 Design Studio below and my installation details.

ctunder77_2-1700020515143.png

 

ctunder77_0-1700019448487.png

Thanks in advance.

0 Kudos