How to use S32K344 EVB-Q257 on-board debugger

cancel
Showing results for 
Search instead for 
Did you mean: 

How to use S32K344 EVB-Q257 on-board debugger

Jump to solution
1,049 Views
ZhouYiChuan
Contributor III

Dear Nxp experts:

From document 'S32K3X4EVB-Q257_HW-UM.pdf', there is an On-Board debugger . 

K344EVB-OBD.PNG

But how can I connect the EVB to debug from S32DS V3.4? 

In S32DS V3.4, there is only SEGGER-J-link debug available.

K344Test_debugConfig.PNG 

FreeMaster was also installed on my laptop, but it seems doesn't support debugging either. 

And my code is also attached for you information .

(in fact , it is created by S32DS V3.4 as a simple example project)

thanks and BR

Zhou YiChuan

0 Kudos
1 Solution
971 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

do you have NXP GCC v10.2 installed? This seems to be missing based on Console output.

Check menu Help->S32DS Extension and Updates

PetrS_0-1644918604379.png

BR, Petr

 

View solution in original post

0 Kudos
12 Replies
1,041 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

check if interface appears in PC's Device Manager.
After USB cable connection I can see 

PetrS_0-1644413402325.png

Then within Debug Configurations of the S32DS 3.4 select desired project debug config from "GBD PEMicro Interface Debugging" and within PEmicro Debuger tab select below interface

PetrS_1-1644413672695.png

Finally click on Debug from this DEbug config window.

BR, Petr

Tags (1)
0 Kudos
1,029 Views
ZhouYiChuan
Contributor III

hello Petr:

thanks a lot. Your suggestion is tried but I got a 'Error while launching command --version' , like below:

Could you please give me further support? I'm trapped . 

launch_problem.PNG

 For your reference, Following possible combinations are tried, but same launching error is got.

1) the P&E multi-link 2.0 device works well in my device manager (my window 10 is Chinese, I translate the status hint into English)

usb-device.PNG

2) in the S32DS V3.4 debug configurtations window, all K344 device options (K344 EMU, K344-SECUREDEBUG) are tried

SelectDevice.PNG

3) flashing mode and Debug mode of FS26 are also tried by different jumper setting on EVB J685

FS26-mode.PNG

thanks and BR

Zhou YiChuan

0 Kudos
963 Views
Guofred
Contributor III

Hi @ZhouYiChuan ,

Thanks for sharing the information.

i can see you build finished successful, if you ignore error and click OK,  can be normal download the firmware.

on the other hand, all path should not have Chinese  characters, kindly help to try to do it again.

Guofred_0-1644931187345.png

 

Best regards.

Guofred

 

0 Kudos
956 Views
ZhouYiChuan
Contributor III

Hi, Goufred:

The building of very simple project is OK, but even I click on the 'OK' button, the debug session failed. 

And the port_example project can't be built.  I'm still fighting with it. 

thanks and BR

Zhou YiChuan

0 Kudos
1,014 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

try to follow getting started guide https://www.nxp.com/document/guide/getting-started-with-the-s32k3x4evb-q257-evaluation-board:GS-S32K.... Probably you did it.
Open/debug  some demo example and use its Debug configuration. i used e.g.

PetrS_0-1644585479836.png

It is connected properly and can be debugged.

BR, Petr

0 Kudos
992 Views
ZhouYiChuan
Contributor III

Hi Petrs:

I tried as the getting started guide https://www.nxp.com/document/guide/getting-started-with-the-s32k3x4evb-q257-evaluation-board:GS-S32K.... . told me.

But the building of Port_Example_S32K344 failed, so I created a very simple example to start the debugging work.

Your support for the building failure is also very appreciated because I have no idea for it either.

the error hint is:

arm-none-eabi-gcc.exe: fatal error: cannot execute 'as': CreateProcess: No such file or directory
compilation terminated.
make: *** [src/subdir.mk:20: src/main.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [generate/src/subdir.mk:51: generate/src/Dio_Cfg.o] Error 1

but the compiler didn't tell me which file or directory can't be found . So I don't know how to fix it.

The whole project and S32 DS console output are attached.

I'd like to describe some other things when I was doing 'new project from example'

the file 'example_Port.mex' was opened as the guideline .

1) S32 DS  told me -- the 'example_Port.mex' is created by earlier version tool, if saved, couldn't be opened with earlier version tool .....

But it doesn't matter.

PortExample_MexWarning.PNG

2) It told me the Pin configuration is not enabled. I enabled it, but in fact , I thinks it is not important because SIUL is not used in the example.

PortExampleConfig.PNG

Not matter I enable or disable the Pin configuration, the 6 building errors are same. 

thanks and BR

YiChuan

 

 

0 Kudos
958 Views
Guofred
Contributor III

Hi @ZhouYiChuan ,

Yes, i use the sample code to compile. it is normal work.

you can check you GCC 1728  and linked resource path again. thanks.

Guofred_1-1644932025626.png

 

Guofred_2-1644932128116.pngGuofred_3-1644932167791.png

Best regards.

Guofred

 

0 Kudos
972 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

do you have NXP GCC v10.2 installed? This seems to be missing based on Console output.

Check menu Help->S32DS Extension and Updates

PetrS_0-1644918604379.png

BR, Petr

 

0 Kudos
919 Views
ZhouYiChuan
Contributor III

@PetrS,
@Guofred,

thanks a lot for your kind support!

After the building environment was setup on another laptop, the building and debug of port_example project succeeded. 

the laptop is Thinkpad with Intel CPU.

I don't know why the S32DS V3.4 on the  laptop with AMD CPU doesn't work.

I'll re-install the S32 DSV3.4 and update package on it. 

thanks and br

0 Kudos
910 Views
Guofred
Contributor III

Hi @ZhouYiChuan ,

Thanks for sharing the information.

i'm also curious that what reason caused this issue. as usual, the software compile environment has a little requirement, such as Linux, windows 32/64bit, GCC10.2 etc. would you like kindly help to check it again and clarify this issue. thanks.

Best regards.

Guofred.

0 Kudos
868 Views
ZhouYiChuan
Contributor III

Hi, @Guofred:

After re-install the S32K344 tool-chains on the laptop with AMD CPU, the port_example can be built. 

What is the root cause of the issue before re-installation, sorry I don't know.

thanks and BR

ZhouYiChuan

0 Kudos
961 Views
ZhouYiChuan
Contributor III

hello Petrs:

the NXP GCC V10.2 and V92. are all installed, maybe there is a conflict.

But the NXP GCC V9.2 can NOT be uninstalled because there is dependency with S32Kxx development package

NXPGCC.PNG

NXPGCC-2.PNG

Maybe I have to re-install the whole building environment 

thanks and BR

YiChuan

 

 

0 Kudos