Can Tx and Can Rx problem in S32K144 EVB

cancel
Showing results for 
Search instead for 
Did you mean: 

Can Tx and Can Rx problem in S32K144 EVB

222 Views
RajG
Contributor III

Hello all community members, CAN communication not establish in S32K144 EVB 
I have been trying to do Can communication on s32k144 board with examples provided by SDK itself but have no luck in Signal at output. Examples are flexcan_encrypted_s32k144 and can_pal_s32k144.

I saw waveform on CRO at can high/low along with pin on port PTE4/PTE5 but it is not generating at all.

I also configure another CAN1 bus at port PTA12 and PTA13 still it also didn't show any variation in waveform.
Given examples is also not working, first i thought SBC problem might be possible but it is not showing any signal on CRO itself.

I tried same thing in MPC5748G development board and i can see can-tx/rx waveform on pin itself.

Kindly help i have been stuck on this since many days,

Thanks and Regards,
RajG.

0 Kudos
3 Replies

197 Views
danielmartynek
NXP TechSupport
NXP TechSupport

Hello @RajG,

There may be something wrong with the SBC.

Do you power the board with 12V?

Do you have only one board?

 

You can change the FlexCAN0 ports to PTB0/PTB1

But you need to connect the two pins externally into a loop.

danielmartynek_0-1623413753368.png

 

Regards,

Daniel

0 Kudos

184 Views
RajG
Contributor III

Hello @danielmartynek , thanks for reply,
If there is problem in SBC then also signal on pin should appear right?
Yes i have applied external 12V power supply, and I have 1 S32k144 board and 1 MPC5748G board.
I also have Arduino with MCP2515 shield to check CAN

I did what you suggested, and I found following results:
1) PTB1 is usually low if not connected to PTB2
2) PTB2 is usually high if not connected to PTB1
3) Both PTB1 and PTB2 are high if connected to one another pin.
4) I can only sense waveform on CRO if I insert some delay after sending Can signal and I can sense it only once. If I reset, I can again see signal.
The duration is also not fixed, For example i have introduced 1000 millisecond delay then sometime waveform on CRO comes for 3 seconds, sometimes for 5 second and even for 1 sec, its totally random. But it comes only 1 time whenever i reset my board.
5) If I send Can signal without delay, I find no waveform.

need further assistance,
Thanks and Regards,
RajG.

0 Kudos

159 Views
danielmartynek
NXP TechSupport
NXP TechSupport

Hello @RajG,

If there is problem in SBC then also signal on pin should appear right?

The RX pin must reflect the signal on the TX pin, this is because of synchronization ESR1[SYNCH] and arbitration ESR1[BIT1ERR].

That's why the PTB1/PTB2 pins must be connected into a loop if they are not connected to any transceiver.

But now, I understand you can measure some signal on the CAN bus (with the UJA1169 SBC) but it stops if you don't use any delay after a CAN message is sent.

Is the CAN message acknowledged by another node on the bus?

The message must be acknowledged otherwise the FlexCAN will keep sending the message until it is acknowledged.

 

Bosch Controller Area Network (CAN) Version 2.0 PROTOCOL STANDARD

https://www.nxp.com/docs/en/reference-manual/BCANPSV2.pdf

danielmartynek_0-1623757282669.png

 

Regards,

Daniel

 

0 Kudos