CAN DISCONNECTION on S32K144 Evaluation Board (MBD)

cancel
Showing results for 
Search instead for 
Did you mean: 

CAN DISCONNECTION on S32K144 Evaluation Board (MBD)

604 Views
ykarata1
Contributor IV

Dear All,

We are trying to validate an Algorithm/SW on the S32K144 Evaluation Board.

One of the validation step is being able to detect CAN H or CAN L cables disconnection. If disconnection exists longer time than a threshold, our algorithm gives an ERROR. But if it just lower than a threshold, after removing disconnection, it operates as if nothing happened since cable was disconnected less than threshold.

But we observed that after disconnecting and connecting cable again, we can not take any CAN data from S32K144 EVB which should broadcast data periodically. Also we had just observed another issue with CAN that I will describe below. 

Second observation that we have is : At normal operation (in not validation) 

  1. We program the S32K144.
  2. We connect CAN L and CAN H cables. (S32K144-------KVASER------PC_USB------BUSMASTER)
  3. We click to Connect Button on BUSMASTER
  4. We can not see any data on BSUMASTER which is a SW to observe CAN data.
  5. We reset by pushing reset button of S32K144EVB.
  6. We observe data on BUSMASTER.
  7. We click Disconnect Button on Busmaster. Naturally we do not see any data as expected.
  8. We click Connect Button on Busmaster. We do not see any data on Busmaster , we believe that is since S32K144 does not send it.
  9. Again we push reset button on S32K144.
  10. Again we can see CAN data on Busmaster.

And that is not only with BUSMASTER. Same goes with also Matlab and Simulink. 

We need to handle both issues. How can we come up with the solution. What is the problem or the failure we do?

 

Any help will be appreciated.

 

Thansk.

 

 

 

0 Kudos
3 Replies

589 Views
ykarata1
Contributor IV

Dear @PetrS ,

We are using Model Based Design and that is the case what we are facing. We have NDA with you. If you like to give it a try we can share our CAN side of model to you on e-mail. Since we use MBD, we can not use unfortunately Read Register block. We have opened a request for that also. What else we can do? What should we check? Any help will be appreciated.

 

ykarata1_0-1614778698080.png

ykarata1_1-1614778707818.png

 

ykarata1_2-1614778759477.png

 

 

Thanks.

0 Kudos

567 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

unfortunately I do not have experience with MDB, for this please post question to https://community.nxp.com/t5/NXP-Model-Based-Design-Tools/bd-p/mbdt

Without having debug info (registers status) hard to comment.

BR, Petr 

0 Kudos

595 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

not sure what SW is used, but with respect of the FlexCAN module, there should be no issue to sending messages after CAN tool is reconnected back.
After you connect tool again and you expect any CAN data which do not come, try to check FlexCAN register using debugger. See status of the module (MCR register), if any error is detected (ESR1 and ECR ), check message is prepared for TX in used MBs and check IFLAG register.

BR, Petr