CAN 1 is not working

cancel
Showing results for 
Search instead for 
Did you mean: 

CAN 1 is not working

759 Views
naderkhamess
Contributor III

Hello,

problem;we have now a custom hw and i can not send a CAN message

in custom hw : i am trying to run the CAN0 (PTB0, PTB1) and CAN1 (PTA12, PTA13), and connect RX with TX pin and still neither  i can not see waveform in the oscilloscope nor a message with CAN-usb. 

in S32K148 evb : CAN0 is working with on board transceiver on pins PTE4, PTE5, however CAN 1 still can not work, even connecting Rx and Tx together.

could you please give me a hint what to do? 

am i missing any hw settings for the pcb?

my objective is to make either CAN 0 or CAN 1 work run with external CAN transceiver. 

i also tried to read ECR and ESR1 registers, but i still can't tell and identify what might be the issue. 

i tried also PTA6/PTA7 , and PTA12/PTA13.

Thanks. 

Best wishes,

Nader Khamess

@Petr Stancik

2 Replies

654 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

i can recommend below testing...

1. connect TX RX pin together without transceiver and send a message. You should see message repeatedly due to missing ACK. TX error counter is 0x80 and module is in error passive. If you see anything else, you have wrong pin setting

2. connect TX RX pins to transceiver normally and have it unconnected from the bus. Send a message. You should see the same as above. If not transceiver could be disabled or it is not terminated.

3. connect transceiver to the bus with other nodes (e.g. CAN tool), send/receive messages. If any error is detected most probably the CAN bit timing is not right. Be sure all nodes use same bitrate and sample point.

You can use below tool for a calculation

https://community.nxp.com/docs/DOC-342618 

BR, Petr

654 Views
naderkhamess
Contributor III

Hi Petr,

ok thank you very much worked now in NXP evaluation board after following your steps. 

Best wishes,

Nader

0 Kudos