ARM compiler V5 with S32K144

cancel
Showing results for 
Search instead for 
Did you mean: 

ARM compiler V5 with S32K144

88 Views
Ahmed2
Contributor I

I am compiling my code for S32K144EVB with ARM compiler version 6 (V6.15) in Keil with no problems at all.

But when compiling the same code without any modifications with ARM compiler version 5 (V5.06 Update 7) , the code enters the HardFault Handler once it tries to jump to main(). However, the output of the compilation process gives me 0 errors, 0 warnings.

I suspect that the linker is the root cause of that problem by not putting the code into the code section correctly. I found also in the RTM_4.0.1 Release Note the following. I don't know if this indicated that drivers should not be compiled with ARM compiler version 5 for some reason ???

image.png

Thanks

 
0 Kudos
2 Replies

68 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

According to the "6. Supported hardware and compatible software" of S32SDK_for_S32K1xx_RTM_4.0.1_ReleaseNotes, please use the version list in it or newer version.

6. Supported hardware and compatible software.png

There may be incompatibility issues for earlier versions.


Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

 

59 Views
Ahmed2
Contributor I

Plenty of thanks for your response. 

I need to use V5 not only V6 in my project for some backward compatibility issues.

Please, recognize the following 2 pictures:

This is when I use compiler V6:

Ahmed2_0-1612691240948.png

This is when I use V5:

Ahmed2_1-1612691297851.png

You will find that the startup codes (In assembly and in C) have disappeared. Does this mean that I can not use those provided startup codes of V6 while using V5 ?

Because I tried to copy those files and use them directly when compiling with V5, the code compiles but no "read" and "write" permissions are displayed when debugging the code with the debugger and getting into that Hardfault I mentioned before.

If the answer is "yes" then what changes can be made to make those startup codes compatible with V5 (if it is possible) ?

 

Best Regards,

Ahmed Gamal

0 Kudos