SDK required although I installed the latest version of SDK

cancel
Showing results for 
Search instead for 
Did you mean: 

SDK required although I installed the latest version of SDK

589 Views
abderrahimjamao
Contributor III

Hello, I have a problem when I try to install an existing project.

Labels (1)
0 Kudos
6 Replies

322 Views
dianabatrlova
NXP TechSupport
NXP TechSupport

Hello,

The MTRDEVKSBNK144 example code is built on an older SDK EAR 0.8.6 which is not supported by the new S32DS for AMR v 2.2. Because between the SDK versions are differences the easiest way will be to use the S32DS for ARM v 2018.R1. It is possible to import and run this example code to the S32DS for ARM v 2018.R1 with a few changes in the properties. S32 Design Studio IDE for Arm® based MCUs | NXP 

This question have been discussed here:

https://community.nxp.com/message/1278208 

I hope it helps.

Best regards,

Diana

0 Kudos

322 Views
abderrahimjamao
Contributor III

ok, thank you so much. 

0 Kudos

322 Views
dianabatrlova
NXP TechSupport
NXP TechSupport

Hello,

If you will have any difficulties with importing MTRDEVKSBNK144 to S32DS ARM v 2018.R1, please, let me know.

Best regards,

Diana

0 Kudos

322 Views
abderrahimjamao
Contributor III

Thank you very much I managed to import the project but I have an error when I debug the project.debug.PNG

0 Kudos

322 Views
dianabatrlova
NXP TechSupport
NXP TechSupport

Hello,

What happens when you click the "Retry" button?

Are you able to build the project without any error?

May I see your debug configuration?

For example, I'm using OpenSDA so my settings see below:

pastedImage_2.png

Best regards,

Diana

0 Kudos

322 Views
abderrahimjamao
Contributor III

thankyou, it was a bad contact between the shield and the board. 

0 Kudos