S32K118 recovery on debug connection failure

cancel
Showing results for 
Search instead for 
Did you mean: 

S32K118 recovery on debug connection failure

Jump to solution
946 Views
wei_w_he
Contributor IV

Dear Officer,

We had a SK32K118 EVB board working fine previous, then after playing around with the "CAN bootloader" project then suddenly we are not able to connect with the board via "OpenSDA Embedded -USB Port". (We will always jump to P&E assistant popup then failed on connection.)

After searching around, it seems some memory has been corrupted? And how can we recover from this case? Any method to performa a entire re-falsh the chip?

Tks and best regards

He Wei

 

Labels (1)
0 Kudos
1 Solution
886 Views
dianabatrlova
NXP TechSupport
NXP TechSupport

Dear He Wei,

 

Thank you for the information.

Unfortunately, there can be many causes. It is hard to say if just an SBC chip or the whole board is damaged.

 

Best regards,

Diana

View solution in original post

6 Replies
937 Views
dianabatrlova
NXP TechSupport
NXP TechSupport

Hello He Wei,

 

Can you share the PrintScreen of the failure?

Can you tell me the state of LED D1 located on the board?

Please, restart S32DS/PC and try to create a new empty project and select the option below in the debug configuration.

dianabatrlova_0-1607349710291.png

 

Best regards,

Diana

0 Kudos
926 Views
wei_w_he
Contributor IV

Dear Diana,

1). The error print is:

wei_w_he_0-1607390759053.png

2) LED D1 is always off. (Further, D2 and D3 will be On if selecting 3.3V but D3 will be off if selecting 5V)

3) I create a empty S32K118 project and select the option as you recommend, the same error appear.

4) Further, also we connected with a multilink device and try the "USB Multilink-USB port" option but got same error too.

Please advise.

Tks and best regards

He Wei

 

 
 

 

 

 

 

 

 

0 Kudos
915 Views
dianabatrlova
NXP TechSupport
NXP TechSupport

Hello,

 

When powered through USB, LEDs D2 and D3 should light green, also, in the case of selecting 5V.

Can you, please, measure VDD_MCU whether the MCU is powered (in both cases)?

 

Can you share the last project which you loaded into MCU and S32DS version? (I can try to reproduce your issue)

 

Thank you.

Best regards,

Diana

0 Kudos
893 Views
wei_w_he
Contributor IV

Dear Diana,

We measured VDD_MCU and it always LOW (0 Vol) no matter powered from USB (5V or 3V) or external 12V, it shows the MCU itself could be permanently damaged.

BR

He Wei

 

0 Kudos
887 Views
dianabatrlova
NXP TechSupport
NXP TechSupport

Dear He Wei,

 

Thank you for the information.

Unfortunately, there can be many causes. It is hard to say if just an SBC chip or the whole board is damaged.

 

Best regards,

Diana

908 Views
wei_w_he
Contributor IV

Dear Diana,

I will ask my colleague to do the measurement as you mentioned. and I just quickly share what we did to "spoil" this board:

1. We build the " S32K118_CAN_bootloader" from NXP.

2. We go to "Run-> Flash from file.." option to load the ELF file.

Is the issue caused by "Flash from file.."?

Tks nad best regards

He Wei

 

0 Kudos