S32 3.4 with S32K1XX RTM4.0.1 can't Init Flexio_I2S_Slave

cancel
Showing results for 
Search instead for 
Did you mean: 

S32 3.4 with S32K1XX RTM4.0.1 can't Init Flexio_I2S_Slave

Jump to solution
574 Views
Helloyt
Contributor I

Recently,I am trying to transplant some driver demo from s32ds for arm sdk3.0 to s32ds 3.4 with sdk 4.0

in s32k148,but a problem occured as the tittle said

below, sdk 3.0 is short for the IDE s32ds for arm sdk3.0 , sdk 4.0 is short for s32ds 3.4 with sdk 4.0

 

I can use those code to build connection in board after clock and pin init with sdk3.0:1.png

but with the same code above in sdk4.0, i cant init i2s slave

i tried to trace the fault, then i found that if i change the init order ,just put slave init before master init ,slave init can be success but master init failed

i jumped into the function,the i found some difference in sdk3.0 and sdk4.0:

2.png

the function above in sdk3.0, slave->flexioCommon.resourceCount is initialized witch 2, but in sdk4.0 the value is 3

but if i change the value fomr 3 to 2,i even can not finish the slave init and jump to a DefaultISR directly.

what should i do to init both I2S master and slave in sdk4.0 ? i hope that you can help me ,thanks!

Labels (1)
0 Kudos
1 Solution
553 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi Helloyt,

The flexio_i2s (SDK3.0.0) slave mode settings do not follow the recommended settings in the reference manual. The recommended settings were updated to fix some failures.

54.5.7 I2S Slave.jpg

flexio_i2s example will no longer be able to run master and slave on the same device. It will have to be split in two separate examples, master and slave, and you will need two boards to run it.

So you can see there are two separate examples in SDK4.0.0: flexio_i2s_master_s32k148 and flexio_i2s_slave_s32k148

Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

View solution in original post

1 Reply
554 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi Helloyt,

The flexio_i2s (SDK3.0.0) slave mode settings do not follow the recommended settings in the reference manual. The recommended settings were updated to fix some failures.

54.5.7 I2S Slave.jpg

flexio_i2s example will no longer be able to run master and slave on the same device. It will have to be split in two separate examples, master and slave, and you will need two boards to run it.

So you can see there are two separate examples in SDK4.0.0: flexio_i2s_master_s32k148 and flexio_i2s_slave_s32k148

Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------