LPUART calllack to recieve large data

cancel
Showing results for 
Search instead for 
Did you mean: 

LPUART calllack to recieve large data

215 Views
c_joshi
Contributor II

Hi,

I am trying to use LPUART call back function as used lpuart_echo_S32k144. Except that i use it to receive a fixed size of data (around 400 bytes). 

I send around 50 requests one after the other to receive 50 responses (8bytes each)

I receive 8bytes of data at a time, instead of 1U. 

LPUART_DRV_ReceiveData(INST_LPUART1, buffer, 8U); (x50 such responses)

It works successfully for 2 such transfers(ie;16bytes). After 16bytes, i dont receive data, which triggers watchdog.

What can be the reason behind this?

I use  S32DS.ARM.2018.R1 version.

Tags (1)
0 Kudos
3 Replies

119 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hi c.joshi@spike.global‌,

The S32K has by default the WDOG enabled, so in the SystemInit(void) function called in the Reset_Handler the WDOG is disabled, be sure that this section is being executed enabling the following define:

 #define DISABLE_WDOG                 1

Let me know if this helps you.

Best Regards,

Alexis Andalon

0 Kudos

119 Views
c_joshi
Contributor II

Hey Alexis,

The setting is already present as you mentioned.  I dont want to disable watchdog though. I want to receive correctly so that I dont trigger watchdog.

0 Kudos

119 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Dear c.joshi@spike.global‌,

Then where are you feeding the WDOG? You need to feed the WDOG between transfers so the timeout is never reached.

Best Regards,

Alexis Andalon

0 Kudos