Cannot import the Demo project of S32K148EVB

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot import the Demo project of S32K148EVB

118 Views
Contributor III

Hi,

I just got the S32K148EVB board.  

I want to test the Freemaster accroding to the "S32K148EVB-QSG" manual, like this:

pastedImage_3.png

I have burned other test programs, so I need to burn the original demo program "S32K148_EVB_JumpStart_Firmware" right now.

But I got the error below:

pastedImage_1.png

My environment is:

S32 Design Studio for ARM  Version: 2.2

pastedImage_2.png

What should I do?

Is this demo program correct?

0 Kudos
5 Replies

31 Views
NXP Employee
NXP Employee

Hi, 

this project is for older SDK and S32DS - please install S32DS for ARM v2018.R1  https://www.nxp.com/webapp/swlicensing/sso/downloadSoftware.sp?catid=S32-DS-ARM_v2018  

Jiri

0 Kudos

31 Views
Contributor III

hello,Jiri

Nice to see you again.

Actually I have installed both v2018 and v2.2.

When I use the v2018R1, the problem is still there.

pastedImage_1.png

The environment is v2018R1+update11.

Can you help me ?

Thanks!

Lu

0 Kudos

31 Views
NXP Employee
NXP Employee

Hi, 

From the EVB's pdf is this example based on S32K14x EAR v0.8.6 SDK - if I'm correct - this version is part of S32DS v2018.R1 Installation. Please check if this version is present - try to open SDK based example project. 

Jiri

0 Kudos

31 Views
Contributor III

Hi,Jiri

You are right. v2018+update11 does has the S32K14x EAR v0.8.6 SDK.

But the error is still there. 

The error information say it need the S32K14x_07 SDK ?

pastedImage_1.png

Thanks!

Lu

0 Kudos

31 Views
NXP Employee
NXP Employee

Hi, 

um - actually have no Idea which particular version is this example looking for (from pdf it loos that for 0.8.6). I'll move your thread into S32 SDK space - hope someone from SDK team can aswer it. 

Jiri

0 Kudos