The application can no longer enter interrupts when using printf in main() to print a message.

cancel
Showing results for 
Search instead for 
Did you mean: 

The application can no longer enter interrupts when using printf in main() to print a message.

Jump to solution
193 Views
Contributor I

I'm now having a problem when using printf in the main function.
I do observe the messsage from the console.
And the INTVEC is updated,but  the  interrupts can no longer be entered.

INTC.png

Without using the printf,  the interrupts work well.


I configured my project as the follows.

semihosting.png

Is there any connection between the printf and the interrupts?

How can I use the printf  correctly without affecting the interrupts?

Best regards!

Laura

0 Kudos
1 Solution
9 Views
NXP Employee
NXP Employee

Hi, 

the only difference what I can identify is that you are using older version of PE Micro debug plugin. On third screenshot I can see gdbjtag.ppc_1.7.2 . On my machine is latest version - 1.8.3.

pastedImage_1.png

Try to update your PE Micro debug plugin - https://community.nxp.com/docs/DOC-342273

Hope it helps. 

Jiri 

View solution in original post

0 Kudos
6 Replies
9 Views
NXP Employee
NXP Employee

liuww.fnst@cn.fujitsu.com

Jiri is right, you have to update P&E plugin. They have fixed this issue since version 1.7.3

0 Kudos
9 Views
NXP Employee
NXP Employee

Hi, 

I figured out, that my issue is related to MPC5748G only (there is the same Z4 core). I did some test with MPC5744P - and there is no issue - at least with pll + interrupt example with added semihosting console support: 

pastedImage_1.png

Can you please share your project? 

0 Kudos
9 Views
Contributor I

Hi Jiri,

Thanks for your help.

I have also tried the pll + interrupt example . The same issue happened.

The changes I made are as follows.

1.Libraries support

pastedImage_2.png

2. semihosting support

pastedImage_3.png

3. Printf function

pastedImage_1.png

but as you see the application just can't stop at the breakpoint in the PIT0_isr .

Is there anything wrong with my changes above?

Best regards!

Laura

0 Kudos
10 Views
NXP Employee
NXP Employee

Hi, 

the only difference what I can identify is that you are using older version of PE Micro debug plugin. On third screenshot I can see gdbjtag.ppc_1.7.2 . On my machine is latest version - 1.8.3.

pastedImage_1.png

Try to update your PE Micro debug plugin - https://community.nxp.com/docs/DOC-342273

Hope it helps. 

Jiri 

View solution in original post

0 Kudos
9 Views
Contributor I

Hi,

I updated the PE Micro debug plugin and now it works well.

Thanks very much.

Best regards!

Laura

0 Kudos
9 Views
NXP Employee
NXP Employee

Hi Laura, 

thank you for report, I can reproduce your issue. I'll do more investigation and hope will be back with solution. 

Jiri

0 Kudos