S32ds 1.3 to S32ds 2018

cancel
Showing results for 
Search instead for 
Did you mean: 

S32ds 1.3 to S32ds 2018

279 Views
Contributor IV

Hello,

I tried converting my project initially created in version 1.3 to the 2018 version. However it did not find some libraries, for example:

#include "fsl_device_registers.h"

fatal error: fsl_device_registers.h: No such file or directory

How can I fix this?

0 Kudos
1 Reply

6 Views
NXP Employee
NXP Employee

Hello lohrsistemas‌,

The file fsl_device_registers.h comes from the SDK. In newer versions of the SDK, it appears to have been renamed to just device_registers.h. However, you will find that there are many differences between the SDK version used to create the project and the version available in 2018.R1. Unfortunately, in many cases, there is no simple way to migrate from one SDK version to another. You could try to export the Processor Expert settings from previous version and import them into the new version. If this does not work, then you will need to create a new SDK project in the 2018.R1, move your code to this new project and then create new Processor Expert settings with values from the previous version.

Hope it helps,

Mike

0 Kudos