S32K144 Error about "0x410"

cancel
Showing results for 
Search instead for 
Did you mean: 

S32K144 Error about "0x410"

Jump to solution
907 Views
kimmk
Contributor I

Hi,

 

I have some problem in my project. I use S32K144-Q100.

This project use LPTMR module to make up scheduler. (scheduler means periodically operating functions)

When click debug button, 0x410 popup create.

There is some message that No source available for "0x410".

It doesn't problem to run program. but i care about this.

I attached my project, please check some of human error.

 

Regard, 

Minkyu.

Labels (1)
0 Kudos
1 Solution
861 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

 

missing source for address 0x410 means that debugger can't find source code for that address. You can use disassembly feature for that particular address. For some reason - startup_S32K144.S file is not visible debugger on your machine. 

In your project is on that address 0x410 Reset Handler and program already passed through. Break point on main() function is set by default in Debug session config:

jiri_kral_0-1599043542251.png

You can try HW reset. After that is program stopped on the very first instruction:

jiri_kral_1-1599043875477.png

 

It is also possible that you have disabled debug info for assembler: 

jiri_kral_2-1599043977922.png

 

Hope it helps. 

 

Jiri 

 

 

 

View solution in original post

0 Kudos
5 Replies
897 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

 

on 0x410 address is reset handler written in Assembly language. By default - first breakpoint is in main() function  and as you can see on your screenshot - the program is stopped there - address 0x798. 

 

I tried your program - and there is no issue on my side. When you close the 0x410 tab and restart your debug session, is the 0x410 tab shown again?

 

Jiri

0 Kudos
874 Views
kimmk
Contributor I

Hi, Jiri

 

At first, the program is stopped first break point - address 0x798.

I didn't set break point there. Screenshot is initial screen of debug session.

So, I think break point set automatically, that means program is ready to start running?

I don't understand clearly about your comment.

=> on 0x410 address is reset handler written in Assembly language. By default - first breakpoint is in main() function  and as you can see on your screenshot - the program is stopped there - address 0x798. 

 

And the 0x410 tab still show in my debug session.

 

Thank you

BR, minkyu.

0 Kudos
862 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

 

missing source for address 0x410 means that debugger can't find source code for that address. You can use disassembly feature for that particular address. For some reason - startup_S32K144.S file is not visible debugger on your machine. 

In your project is on that address 0x410 Reset Handler and program already passed through. Break point on main() function is set by default in Debug session config:

jiri_kral_0-1599043542251.png

You can try HW reset. After that is program stopped on the very first instruction:

jiri_kral_1-1599043875477.png

 

It is also possible that you have disabled debug info for assembler: 

jiri_kral_2-1599043977922.png

 

Hope it helps. 

 

Jiri 

 

 

 

0 Kudos
897 Views
danielmartynek
NXP TechSupport
NXP TechSupport

Hi Minkyu,

Which version of the S32 Design Studio do you use?

I have imported the project into S32DS R1 and S32DS 2.2 and I don't see this issue.


Thank you,

BR, Daniel

0 Kudos
876 Views
kimmk
Contributor I

Hi, Daniel.

My S32 Design Studio version is 2018.R1.

I try to 2.2 version.

Thank you.

 

BR,

Minkyu

 

0 Kudos